Closed Bug 1093449 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][Clock][Alarm] It is difficult to select time in alarm.

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect, P2)

defect

Tracking

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Unassigned)

References

Details

CONTACT:
  15821566167.		
 
  DEFECT DESCRIPTION:
  It is difficult to select time in alarm.
 
  REPRODUCING PROCEDURES:
  1. Enter "clock->alarm", add a new alarm;
  2. Select time;
  3. It is difficult to select time.--KO
 
  操作步骤:
  1. 进入“时钟->闹钟”,添加一个新闹钟;
  2. 选择时间;
  3. 很难去选择时间。--KO
 
  备注:当滑动分钟列时,它很容易滑动到下面一个时间点。
 
  EXPECTED BEHAVIOUR:
  It is easy to select time.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
  100%
 
  For FT PR, Please list reference mobile's behavior:
  Soul 3.5 FF is OK.
Hi Gary,
Can you check this bug with touch screen issue? I am not sure how much Mozilla can improve this.
Maybe also feature request for UX...
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Flags: needinfo?(gchen)
Adding qawanted for branch checks.
Keywords: qawanted
I can see that in the event that the user wants to select a time adjacent to the current one (e.g. 5:04 to 5:05, or 5:04 to 6:04), they COULD accidentally go further than expected, depending on how fast they move their finger, and whether or not they pay attention to the digits in bold (digits in bold will be the final digit being selected when finger leaves screen). But for me it isn't a problem. This seems like an issue that each user feels differently.

Issue does NOT occur on Flame 2.0, Flame 2.1, and Flame 2.2.

Device: Flame 2.0
BuildID: 20141104053644
Gaia: fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko: 093de6b632c5
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1
BuildID: 20141104070645
Gaia: 9d80d556123553e5fd8acd982192e33807e9e1fe
Gecko: 0953b46ee9a8
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master
BuildID: 20141104041844
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: cadcd47db610
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
since QA can no reproduce this issue, remove ni flag first.
Flags: needinfo?(gchen)
This bug seems to boil down to a matter of opinion (like comment 3 presents). As someone with chubby fingers I often run into touch-issues like this that others do not but even I feel like the performance on the flame is not bad at all. I can see how the HOUR reel can be easy to overshoot your target as you would typically make smaller adjustments there. I don't know if the reel turn speed could be reduced. 

I'm leaving the tracking flags as the QA-Wanted tester set them but really the affected / unaffected status of this bug is really subjective.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Triage:
Low user impact.
blocking-b2g: 2.0M? → ---
blocking-b2g: --- → -
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.