Closed Bug 1093621 Opened 5 years ago Closed 5 years ago

Enable new tablet UI by default on Nightly/Aurora

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 36

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Attachments

(1 file)

The UI structure is in place now. Time to get wider feedback.
Comment on attachment 8516728 [details] [diff] [review]
Enable new tablet UI by default in Nightly (r=mcomella)

Here we go.
Attachment #8516728 - Flags: review?(michael.l.comella)
Comment on attachment 8516728 [details] [diff] [review]
Enable new tablet UI by default in Nightly (r=mcomella)

Review of attachment 8516728 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/NewTabletUI.java
@@ +11,5 @@
>  import org.mozilla.gecko.preferences.GeckoPreferences;
>  import org.mozilla.gecko.util.HardwareUtils;
>  
>  public class NewTabletUI {
>      // This value should be in sync with preferences_display.xml.

Add to this comment to mention how "being in sync" makes sense despite the fact that this is not "true", i.e. what you told me IRL about how the preference is removed in release builds.
Attachment #8516728 - Flags: review?(michael.l.comella) → review+
This may have caused a regression:

Regression: Fx-Team - Robocop Checkerboarding Real User Benchmark - Android 4.0.4 - 65.9% increase
--------------------------------------------------------------------------------------------------
    Previous: avg 17.092 stddev 1.432 of 12 runs up to revision fb567390cb92
    New     : avg 28.347 stddev 0.242 of 12 runs since revision 3b36af7151ec
    Change  : +11.255 (65.9% / z=7.862)
    Graph   : http://mzl.la/1sfsKk0

Changeset range: http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=fb567390cb92&tochange=3b36af7151ec
Backed out due to talos regressions:
https://hg.mozilla.org/integration/fx-team/rev/e7488d6c9af8
https://hg.mozilla.org/mozilla-central/rev/3b36af7151ec
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
This was backed out
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 1091519
Patches from bug 1093621 fix the talos regression. Let's try this again:
https://hg.mozilla.org/integration/fx-team/rev/7ef4eeeace2e
(In reply to Lucas Rocha (:lucasr) from comment #10)
> Patches from bug 1093621 fix the talos regression. 

Wrong bug nr.
I meant bug 1091519.
Backed out again, talos regressions still there.
https://hg.mozilla.org/integration/fx-team/rev/fc30354927a2
https://hg.mozilla.org/mozilla-central/rev/7ef4eeeace2e
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
dammit
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 36 → ---
Quick update: I narrowed down the cause of the regression. It seems the affected talos test doesn't like the fact that we change the toolbar height in the new tablet UI:

http://dxr.mozilla.org/mozilla-central/source/mobile/android/base/toolbar/ActionBarViewFlipper.java#32

Working on a patch now.
Patch is bug 1097316 works around the regression. I'll continue investigating the real cause of the regression in bug 1097318.

https://hg.mozilla.org/integration/fx-team/rev/b8490f38c4da
https://hg.mozilla.org/mozilla-central/rev/b8490f38c4da
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Depends on: 1099158
Forgot to remove the toast notification I think, see above bug.
You need to log in before you can comment on or make changes to this bug.