[Dialer]The incorrect error message is shown when the user attempts to make a phone call without a sim card inserted into the Flame.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: cnelson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-Exploratory-3], URL)

Attachments

(1 attachment)

5.03 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8517012 [details]
log.txt

When the user tries to make a phone call when there is no sim card, they will encounter the wrong error message.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141104001202
2) Pull all sim cards from the Flame in test.
3) Open the dialer app.
4) Try to make a phone call.
5) Notice the incorrect error message will appear.
  
Actual:
The incorrect error message will appear when the user attempts to make a phone call when there is no sim card in the Flame.
  
Expected: 
The correct error message will appear, informing the user that there is no sim card inserted into the Flame.
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Version: 34.0 (2.1)
Firmware: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"

Notes: On Flame 2.2, there is no error message that pops up to inform the user that there is no sim card inserted into the device. 
  
Repro frequency: 100%
See attached: logcat, video clip https://www.youtube.com/watch?v=JoQMRuKrOO4
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue does occur on Flame 2.2(319mb)(KitKat)(Shallow Flash), and Flame 2.0(319mb)(KitKat)(Shallow Flash).

On Flame 2.2, there is no error message at all.

Flame 2.2

Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
Build ID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

On Flame 2.0, the error message is incorrect.

Flame 2.0

Device: Flame 2.0(319mb)(KitKat)(Shallow Flash)
BuildID: 20141104000201
Gaia: fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko: 241e51806687
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Comment hidden (obsolete)
(Reporter)

Comment 3

4 years ago
This issue is reproducible on full flash Flame 2.1 and Flame 2.2.
Flags: needinfo?(cnelson)
Waiting for nomination call from comment 2
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(In reply to Derek Harris [:DerekH] from comment #4)
> Waiting for nomination call from comment 2

Sorry, I meant to leave comment 2 for bug 1093862.

Gabriele, do you know if we have a special string for that case?
Flags: needinfo?(tchung) → needinfo?(gsvelto)
Keywords: regression
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #5)
> Gabriele, do you know if we have a special string for that case?

Correct, that's the string that's supposed to appear if you have no (voice) network connection. What other string would be expected? Something like 'no SIM card present'? We might want to needinfo UX here if we want to make this more specific.
Flags: needinfo?(gsvelto)
Per comment 6.
Flags: needinfo?(cawang)
Duplicate of this bug: 922538
Hi, 

I'd suggest to change the string to:

Title: Missing SIM card 
String: Insert a valid SIM card to continue.

Thanks!
Flags: needinfo?(cawang)

Comment 10

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.