Lockscreen only displays battery icon, not other icons

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: khuey, Assigned: gmarty)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
etienne
: review+
Details | Review | Splinter Review
I've seen this a few times now.  I turn on the screen of the device and the only icon visible in the status bar is the battery.  Once I unlock it the other icons such as signal, music playing, etc will reappear.  What's really crazy is that sometimes if I turn the screen on and off a few times I'll be able to see the lock screen come on with the icons and then all the icons (except the battery) get immediately removed.
Adding qawanted to find a solid STR here.
Keywords: steps-wanted
Hi Kyle,
     Could you tell us the following information please?

1. What Device were you on?
2. What build were you on?

This will help us locate the problem.

Thank You!
QA
Flags: needinfo?(khuey)
This was on a Nexus 5.  I've seen it on builds across several weeks, but I haven't been able to figure out STR yet.  I wouldn't spend too much time on this.
Flags: needinfo?(khuey)
Not able to get this bug on the Flame device. The closest thing I can see is a bug where when camera app is open, the lockscreen icons disappear. Separate bug though.

This bug does NOT repro on Flame kk build: Flame 2.2 KK, Flame 2.1 KK

Actual Result: Not able to get just a battery icon on the lockscreen.

Repro Rate: 0/20

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141106045123
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 0c66a9fd9085
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141105133152
Gaia: 9658b93b412bdcc0f953d668e8c8e68318c99fb8
Gecko: 76880403db44
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: steps-wanted
No repro on Flame - might be specific to Nexus 5
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Another thing that's interesting, when this happens the screenshot button combo doesn't work.

I'll try to get a logcat next time it happens.
Component: Gaia::System::Lockscreen → Gaia::System
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → gmarty
My STR with SHB enabled:
Have link on homescreen (my case news.orf.at)
Open link and wait a few seconds
press power button
wait a few seconds
press power button again.

The lockscreen only shows the battery and wifi icon. The 2 network icons are missing.
(Assignee)

Comment 8

4 years ago
Created attachment 8538499 [details] [review]
Github PR

What we need here is to show the maximised status bar on the lockscreen.
Etienne, can you have a look at this patch that implements this?
Attachment #8538499 - Flags: review?(etienne)
Comment on attachment 8538499 [details] [review]
Github PR

The change looks A-ok! But at this point I don't think we can consider a statusbar bug fixed without a marionette test.
I'm thinking: launching an app, locking, and checking that the maximized version is displayed.
Attachment #8538499 - Flags: review?(etienne)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8538499 [details] [review]
Github PR

I just added a Marionette test for that.
Attachment #8538499 - Flags: review?(etienne)
Comment on attachment 8538499 [details] [review]
Github PR

Awesome, thanks!
Attachment #8538499 - Flags: review?(etienne) → review+
(Assignee)

Comment 12

4 years ago
Landed in master in https://github.com/mozilla-b2g/gaia/commit/c2da2bafd4e809317e2ca70c9bf5c11136a32818
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 13

4 years ago
Verified the issue is fixed on 2.2 Flame

All icons are displayed on the status bar when screen is locked

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
===================================================================
The issue still DOES repro on 2.1 when followed steps in comment 7
===================================================================
Adding "verifyme" for 2.1 patch uplift
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: unaffected → affected
status-b2g-v2.2: unaffected → verified
Flags: needinfo?(ktucker)
Note, this won't be uplifted to 2.1.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.