Closed Bug 1094042 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][ANR][Email][Browser]It will pop up ANR information when open the URL from email

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected)

RESOLVED DUPLICATE of bug 991489
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(6 files)

+++ This bug was initially created as a clone of Bug #807371 +++
 +++ This bug was initially created as a clone of Bug #783231 +++
 Created an attachment (id=936894)
 jrdlog
 
 DEFECT DESCRIPTION:
 It will pop up crash information when open the URL from email
 
 REPRODUCING PROCEDURES:
 1.Launch email->open an email which contains pictures attached->click download
 URL of the file attachment->The browser will pop up ANR information->KO1
 2.After a min,the hadset will pop up a notification in staturs bar that the file was downloaded successfully,but press it ,we still can not preview the file->KO2
 
 
 NOTE:
 Reporter :minhong.li/李敏虹
 Tel:0752-2639590(63590)
 Email:minhong.li.com
 
 
 EXPECTED BEHAVIOUR:
 KO:Can download the attachment from browser
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 mid
 REPRODUCING RATE:
 5/5
 For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #783231 description ++++++++++
 ++++++++++ end of initial bug #807371 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached image screenshot
Attached file jrdlog
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. 
I think this bug is website related. Can you try repo with u.163.com?
Thanks!
Flags: needinfo?(fan.luo)
Blocks: Woodduck
Hi Gary,
Could you please help to check the problem? Thanks!
Flags: needinfo?(gchen)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991489
Attached file logcat.txt
(In reply to Josh Cheng [:josh] from comment #3)
> Hi Norry,
> qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. 
> I think this bug is website related. Can you try repo with u.163.com?
> Thanks!

Hi Josh,
This bug can be reproed on Woodduck 2.0m and Flame 2.0.

I login a 163 mail account on phone, and send a mail with 4M video attachment from PC outlook to this 163 account. When mail is recieved, tap it to check, there is one link to download the attachment, See "Mail View.png". If I tap the link, it will go to a URL, and Crash info page will pop up. After 13mins, a notification that attachment is downloaded successfully will pop up on the notificationbar. If I tap the notification, the attachment(video) can be played.

I can't repro on Flame 2.1/2.2, because when I tap the mail, it will prompt me that it is large mail, whether to download attachment, if I select Yes, the attachment will be downloaded. So, there is no download link in the mail detail view.

Attached: Mail View.png, Download info.png, Crash infor.png, logcat.txt
Found time: 10:42 crash,  10:55 attachment download successfully.

Flame 2.0:
Gaia-Rev        5ee26701a4d8db266bfb203b2179f686ce14d8b6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/dbf49343e889
Build-ID        20141105160207
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141105.193002
FW-Date         Wed Nov  5 19:30:12 EST 2014
Bootloader      L1TC00011880
--------------------------------------
Woodduck version:
Gaia-Rev        6dea064f6872a42657297621807d6d35453a7e7b
Gecko-Rev       9b8934fbb515c7ac026ecf0557d44feec888c4ef
Build-ID        20141106050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1415221760
FW-Date         Thu Nov  6 05:09:43 CST 2014
Flags: needinfo?(fan.luo)
No longer blocks: Woodduck_Blocker
Per comment #5, it dup to bug 991489, so clear my ni flag.
Flags: needinfo?(gchen)
You need to log in before you can comment on or make changes to this bug.