Browser eats up 100% of CPU when images animate

RESOLVED FIXED in Future

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: dr, Assigned: pavlov)

Tracking

({memory-leak})

Trunk
Future
x86
Windows 2000
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The browser eats up 100% of the CPU when several images on the page are 
animated. For example:

  http://sleepy.at/~dr/portfolio

This is a sporadic bug, and it seems to happen only slowly. Just watching the 
Windows task manager for a few minutes, it seems like memory is leaking at a 
steady rate of about 20K/sec and eventually the CPU starts to get pegged.

I observe this bug on Win2k using Netscape 6.2 (mozilla0.9.4.1). In contrast, 
IE6 eats up only about 1 or 2% of my CPU on this page and doesn't seem to leak 
(unless the task manager is lying to me).

Updated

17 years ago
Keywords: mlk

Comment 1

17 years ago
Dupe of bug 99636?
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Updated

17 years ago
Blocks: 119597

Comment 2

17 years ago
WFM 2002060704 win2k

Comment 3

17 years ago
This has been fixed by bug 129115 so far.
marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.