Tapping the tabs button after clearing browser history results in a white screen

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Bebe, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Reporter

Description

5 years ago
Description:

Tapping the tabs button in the browser app after clearing the browser history results in a white screen.

also after reproducing this the cards view is not accessible


Repro Steps:
1. Open the browser app and navigate to a website
2. tap the home button
3. Open the Browser app and check that you have the site you just visited in you browsing history 
4. Open the settings app
5. got to Browsing Privacy and tap clear browsing history
6. tap the home button 
7. Open the Browser app
8. Notice no browsing history 
9. tap the tabs button (or the white area where it should have been)


Actual:
9. The screen is flashing white a few times then we get a white screen

Expected: 
9. Nothing happens as we should not have any tabs or browsing history 


Environmental Variables:
Gaia-Rev        7c9e7cabbde941b976e0e40a3a1d94e21aa9c5e9
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/62990ec7ad78
Build-ID        20141105040206
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880

V188-1 + shallow flash latest mozilla central

Reproducible manually: YES

Repro frequency: 5/5

Video:
https://drive.google.com/file/d/0B85kL88zfLi1NmNDUlRhZ1NYYmM/view?usp=sharing
Nominating for blocking. I am able to reproduce this on the latest Flame nightly. The window manager button seems to be missing in this instance as well.
blocking-b2g: --- → 2.2?
(In reply to Florin Strugariu [:Bebe] from comment #0)
> also after reproducing this the cards view is not accessible

This is another issue which is being dealt with in bug 1092543.


> 9. tap the tabs button (or the white area where it should have been)
> Actual:
> 9. The screen is flashing white a few times then we get a white screen

I'm able to reproduce this invisible button issue & screen flashing issue on 2.2. These two issues are NOT present in 2.1, but unfortunately (see below),


> Expected: 
> 9. Nothing happens as we should not have any tabs or browsing history

This expected behavior is NOT present in 2.1 either. In 2.1 the show window button is visible at step 9 and after tapping on it, browsing history is shown in tabs/windows.

I will work on finding the window for the white screen behavior but for the expected behavior I think another bug needs to be filed and it doesn't look like a regression since it happens on 2.1.
QA Contact: pcheng
Regression window shows that this issue is related to bug 1092543 afterall because they're both broken by the same bug 1073252.

Also please be noted that the 'Working' build's behavior here is NOT the expected behavior because it still shows history, as mentioned on comment 2.

-------

mozilla inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141031020755
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 287ddaf9b9df
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141031021654
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 52d9cbc1d78e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=287ddaf9b9df&tochange=52d9cbc1d78e

Caused by Bug 1073252.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
possibly broken by Bug 1073252. Can you take a look Robert?
Blocks: 1073252
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(roc)
QA Contact: pcheng
Please retest after 1092543 has been fixed.
Flags: needinfo?(roc)
Depends on: 1092543
Pi Wei, please restest this now that bug 1092543 has been resolved as fixed. Thanks!
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage-]
Flags: needinfo?(pcheng)
Issue is verified fixed on latest 2.2.

Observed behavior: At step 9 of original STR the device does NOT display a white screen (browsing history is still displayed though, as mentioned in comment 2).

Device: Flame 2.2 Master
BuildID: 20141112070408
Gaia: 65ce58778f65c5b39d9e558e02417c9954d55d6e
Gecko: cf9eafef4ffa
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(pcheng) → needinfo?(jmitchell)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → FIXED
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.