[card view] card view is totally broken - cards not visible, swiping is glitched

VERIFIED FIXED in Firefox 36

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dietrich, Assigned: roc)

Tracking

({regression, smoketest})

unspecified
2.1 S9 (21Nov)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox34 wontfix, firefox35 wontfix, firefox36 fixed, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [firefoxos-bsp-london][systemsfe])

Attachments

(4 attachments)

Reporter

Description

5 years ago
Flame, nighly channel (master + m-c), Nov 1.

STR:

1. open a few apps
2. open card view

Expected: apps are visible, can swipe between them

Actual: default view is empty black screen. swiping shows brief flashes of a card (or something).
Whiteboard: [firefoxos-bsp-london]
Posted file cardview.txt
Logcat captured while issue is reproduced.
This has broken a core system feature. Can we get a regression window to see what broke it and back it out?
Keywords: qawanted
How did this not break any tests? :(
This issue is observed on Master 2.2 KK on flame devices today
Results: default view is empty black screen. swiping shows brief flashes of a card (or something).
Repro: 9/10

Environmental Variables:
----------------------------------------------
Device: Flame 2.2
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
----------------------------------------------

This issue is also a smoketest blocker: adding appropriate keywords.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent, smoketest
[Blocking Requested - why for this release]:
Functional regression of a core feature which also fails smoketests.

Window already requested.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Contact: jmitchell
Central Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141031125656
Gaia: 5964f1339f37e7595aff7de7512b8529bc640b76
Gecko: a264cdd47217
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken:
Device: Flame 2.2
Build ID: 20141031131456
Gaia: 5964f1339f37e7595aff7de7512b8529bc640b76
Gecko: 12ac66e2c016
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: 5964f1339f37e7595aff7de7512b8529bc640b76
Gecko: 12ac66e2c016
First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 5964f1339f37e7595aff7de7512b8529bc640b76
Gecko: a264cdd47217

Gecko pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a264cdd47217&tochange=12ac66e2c016

---------------------------------------------------------------------------------------
Mozilla-Inbound Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141031020755
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 287ddaf9b9df
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken:
Device: Flame 2.2
Build ID: 20141031021654
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 52d9cbc1d78e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 52d9cbc1d78e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 8ae6598f3ab7b0c34ac42a73083ddb74266affba
Gecko: 287ddaf9b9df

Gecko pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=287ddaf9b9df&tochange=52d9cbc1d78e


Broken by  Bug 1073252 - can you take a look Robert?
Blocks: 1073252
Flags: needinfo?(roc)
QA Contact: jmitchell
Whiteboard: [firefoxos-bsp-london] → [firefoxos-bsp-london][systems-fe]

Updated

5 years ago
Duplicate of this bug: 1093412
In this video (taken from my 2.1 Flame, yay?) you can just about see me launching task manager/cards view from the Settings up. You briefly see the cards view before the screen goes black. Swiping left/right you get a glimpse of content before it too goes black. As far as I can tell the task manager itself is working fine, and even though you cant see what you are swiping, you can actually switch task - the events are getting through. That explains why no tests barfed.
Whiteboard: [firefoxos-bsp-london][systems-fe] → [firefoxos-bsp-london][systemsfe]
I'm looking into this. The blank screen is caused by my HWC changes but I don't know why yet.
Assignee: nobody → roc
Flags: needinfo?(roc)
Posted patch fixSplinter Review
We really need some kind of testing of HWC!
Attachment #8517177 - Flags: review?(sotaro.ikeda.g)
Reporter

Comment 12

5 years ago
Roc, the keyboard on Flame nightly build for me is also not being painted, is just a black area of the screen (however, touch events working fine).

Would that be this same bug, or should I file a separate bug for it?
Flags: needinfo?(roc)
That works for me, so it's very likely fixed by this patch. Wait for this to land and then file a bug if you're still seeing problems.
Flags: needinfo?(roc)
Comment on attachment 8517177 [details] [diff] [review]
fix

Confirmed that the problem is fixed on master flame-kk by applying the patch.
Attachment #8517177 - Flags: review?(sotaro.ikeda.g) → review+
(In reply to Dietrich Ayala (:dietrich) from comment #12)
> Roc, the keyboard on Flame nightly build for me is also not being painted,
> is just a black area of the screen (however, touch events working fine).
> 
> Would that be this same bug, or should I file a separate bug for it?

Bug 1092608 is on file for the Black keyboard issue.
Blocks: 1094274

Updated

5 years ago
blocking-b2g: 2.2? → 2.2+
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/76f74579c683
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1094428
Duplicate of this bug: 1094374
Duplicate of this bug: 1092608
This issue is verified fixed on Flame 2.2.

Result: Card view is fixed and working properly.

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED

Updated

5 years ago
Blocks: 1088452
Target Milestone: --- → 2.1 S9 (21Nov)
This issue has been verified successfully on Flame 2.1.
See attachment: 1647.MP4
Reproducing rate: 0/5

Step:
1. open a few apps
2. long tap Home key to open card view

Actual result: 
All apps are visible in recent app page, and you can swipe between them.

Flame 2.1 version:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.035005
FW-Date         Thu Nov 27 03:50:16 EST 2014
Bootloader      L1TC00011880
You need to log in before you can comment on or make changes to this bug.