Closed Bug 1094349 Opened 7 years ago Closed 6 years ago

Various rendering problems since introduction of D2D 1.1

Categories

(Core :: Graphics, defect)

35 Branch
defect
Not set
major

Tracking

()

RESOLVED INVALID
Tracking Status
firefox35 - disabled
firefox36 + affected

People

(Reporter: kael, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

In response to the frequent crashes from 1091903, I tried disabling D2D 1.1.

Disabling it via the use1_1 pref fixes the crashes but then the browser's rendering periodically breaks, with all my windows becoming blank white. That state never recovers so I have to terminate firefox.

Disabling it by removing d2d 1.1 from the backends list(s) causes various bitmaps in the UI to stop rendering; this is consistent across browser restarts and machine reboots. This reproduces on a clean profile.

Here's about:support from the laptop with this issue:

Application Basics
------------------

Name: Firefox
Version: 35.0a2
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Multiprocess Windows: 0/3

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-a7398076-b2a6-4878-b026-5eeaf2141103
Submitted: 2 days ago

Report ID: bp-833188a8-6617-4b49-961e-ade542141103
Submitted: 2 days ago

Report ID: bp-2cca84df-9c08-453a-8f93-55b0a2141103
Submitted: 2 days ago

Report ID: bp-50c3f73f-9679-4a86-8f96-069332141103
Submitted: 2 days ago

All Crash Reports (including 1 pending crash in the given time range)

Extensions
----------

Name: NoScript
Version: 2.6.9.3
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Rikaichan
Version: 2.07
Enabled: true
ID: {0AA9101C-D3C1-4129-A9B7-D778C6A17F82}

Name: Rikaichan Japanese-English Dictionary File
Version: 2.01.130701
Enabled: true
ID: rikaichan-jpen@polarcloud.com

Name: Cookies Manager+
Version: 1.5.2
Enabled: false
ID: {bb6bc1bb-f824-4702-90cd-35e2fb24f25d}

Name: Download Manager (S3)
Version: 3.05
Enabled: false
ID: s3download@statusbar

Name: Gecko Profiler
Version: 1.14.2
Enabled: false
ID: jid0-edalmuivkozlouyij0lpdx548bc@jetpack

Name: JIT Inspector
Version: 0.5.0.0
Enabled: false
ID: bhackett@mozilla.com

Name: Lazarus: Form Recovery
Version: 2.3
Enabled: false
ID: lazarus@interclue.com

Name: Theme Font & Size Changer
Version: 32.3
Enabled: false
ID: {f69e22c7-bc50-414a-9269-0f5c344cd94c}

Name: WebPG for Firefox
Version: 0.9.2
Enabled: false
ID: webpg-firefox@curetheitch.com

Graphics
--------

Adapter Description: Intel(R) HD Graphics Family
Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM: Unknown
Device ID: 0x0a16
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 9-9-2013
Driver Version: 10.18.10.3304
GPU #2 Active: false
GPU Accelerated Windows: 3/3 Direct3D 11 (OMTC)
Subsys ID: 397817aa
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20141104004002
browser.startup.homepage_override.buildID: 20141104004002
browser.startup.homepage_override.mstone: 35.0a2
browser.tabs.warnOnClose: false
dom.mozApps.used: true
extensions.lastAppVersion: 35.0a2
font.internaluseonly.changed: true
font.name.serif.x-western: Cambria
gfx.content.azure.backends: direct2d,cairo
gfx.direct3d.last_used_feature_level_idx: 0
media.gmp-gmpopenh264.lastUpdate: 1412253696
media.gmp-gmpopenh264.path: C:\Users\Katelyn\AppData\Roaming\Mozilla\Firefox\Profiles\8995t3of.default\gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.1
media.gmp-manager.lastCheck: 1415212683
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1415163201
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
security.tls.version.max: 1
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1414678274

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: true
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.7
Version in use: 4.10.7

NSS
Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

NSSSMIME
Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

NSSSSL
Expected minimum version: 3.17.2 Basic ECC
Version in use: 3.17.2 Basic ECC

NSSUTIL
Expected minimum version: 3.17.2
Version in use: 3.17.2

Experimental Features
---------------------
We should probably disable this on Aurora.
Seems that disabling it is causing some issues as well?
(In reply to Milan Sreckovic [:milan] from comment #2)
> Seems that disabling it is causing some issues as well?

Fixing that should be a high priority. We don't want to repeat what happened with OMTC.
For reference, I'm also seeing some rather strange rendering artifacts on my primary desktop since D2D 1.1 landed. I'm going to force it off and see if things are okay there.
Removing d2d 1.1 from the backends list on my desktop (with gtx 670) produces the same missing bitmaps in chrome & content that I see on my laptop. So I don't think that's a driver issue.
You need to disable both USE1_1 and remove direct2d1.1 from the backend lists. Let me know if that works better.
That fixes the missing bitmaps on both my machines, thanks.
[Tracking Requested - why for this release]:
D2D 1.1 is still active on 35, and rendering issues are something we need to be careful with right now.
Blocks: 902952
Assignee: nobody → bas
Tracking (for what Kairo said).
(In reply to Sylvestre Ledru [:sylvestre] from comment #9)
> Tracking (for what Kairo said).

Well, we have since disabled D2D 1.1 on Aurora, so it's unaffected now. Or rather, the bugs are disabled. ;-)
OK! thanks for the info!
Milan, do you know what is the plan with D2D for 36? Thanks
Flags: needinfo?(milan)
Summary: Various rendering problems since introduction of D2D 1.1 on Aurora → Various rendering problems since introduction of D2D 1.1
(In reply to Sylvestre Ledru [:sylvestre] from comment #12)
> Milan, do you know what is the plan with D2D for 36? Thanks

I'll let Bas answer.
Flags: needinfo?(milan) → needinfo?(bas)
(In reply to Sylvestre Ledru [:sylvestre] from comment #12)
> Milan, do you know what is the plan with D2D for 36? Thanks

My hope is it can stay on. I believe there's still one or 2 issues which might still need to be fixed though. As far as I know however, most of the glitches should be gone and fixed.
Flags: needinfo?(bas)
Bug 1091903 is fixed now. In addition to that this bug was really more about wrongly disabling D2D 1.1 than anything else.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.