Closed Bug 1094550 Opened 6 years ago Closed 6 years ago

Unable to create a new account because Year of Birth dropdown doesn't work

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect, P3)

defect

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: krupa.mozbugs, Assigned: rudyl)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot
Connectivity: Wifi
SIM used:
Gaia/device: 2.1/flame
Platform version: 34.0
Build Identifier: 20141016001201
Git commit info: 2014-10-15 21:08:45 477a9e61


steps to reproduce:
1. Install https://marketplace.firefox.com/app/in-app-payment-tester-1 on your flame device
2. Change the environment to stage and click Pay
3. Click on 'Create an account'
4. Try to register for a new account by entering email, password and pick your YOB

expected behavior:
Year of Birth dropdown selection works


actual behavior:
Clicking on Year of birth field doesn't show the dropdown making selection impossible

11-05 18:16:19.307 E/GeckoConsole( 1083): Content JS ERROR at app://keyboard.gaiamobile.org/gaia_build_defer_index.js:220 in StateManager.prototype._updateActiveState/<: TypeError: this.app.inputContext is null

NOTE: The dropdown works fine via marketplace but is broken during in-app purchases. I don't think it is an app-specific bug. needinfo'ing Stuart for confirmation.
Flags: needinfo?(scolville)
Yep this is fxa-content-server code I think. Although that looks like platform code that's breaking.

Assigning to and needsinfo'ing ckarlof for input.
Assignee: nobody → ckarlof
Flags: needinfo?(scolville) → needinfo?(ckarlof)
Priority: -- → P1
Assignee: ckarlof → spenrose
Flags: needinfo?(ckarlof)
I can also repro the STR on a flame/2.1.

Additional notes:

Once this error happens (when clicking the drop-down) the keyboard completely dies.

E/GeckoConsole( 1086): Content JS ERROR at app://keyboard.gaiamobile.org/gaia_build_defer_index.js:220 in StateManager.prototype._updateActiveState/<: TypeError: this.app.inputContext is null
More logcat:

E/GeckoConsole(  938): Content JS WARN at app://keyboard.gaiamobile.org/gaia_build_defer_index.js:176 in InputMethodGlue.prototype.sendKey/<: InputMethodGlue: sendKey() rejected with error InputContext got destroyed
E/GeckoConsole(  938): Content JS WARN at app://keyboard.gaiamobile.org/gaia_build_defer_index.js:179 in InputMethodGlue.prototype.setUpperCase: InputMethodGlue: call setUpperCase() when inputContext does not exist.
E/GeckoConsole(  938): Content JS WARN at app://keyboard.gaiamobile.org/gaia_build_defer_index.js:177 in InputMethodGlue.prototype.setLayoutPage: InputMethodGlue: call setLayoutPage() when inputContext does not exist.
Assignee: spenrose → nobody
For clarification, this bug concerns the FxA Web flow on FxOS, not the native FxA flow.
adding qawanted for branch checks, you'll need to use engineering builds and install the app linked in Comment 0.
Keywords: qawanted
[Blocking Requested - why for this release]: this is P1 for an impending Marketplace release.

Reassigning to a Gaia component; may not have the right one.

The keyboard initially works within the TrustedUI. It's the switch of focus to the pulldown that causes or reveals the inputContext garbage collection breakage.
blocking-b2g: --- → 2.1?
Component: FxA → Gaia::System::Input Mgmt
Switching to a window request then.
Did not reproduce shallow flashing with 2.0 today.
QA Contact: aalldredge
I was able to reproduce this issue in latest 2.1 Flame. Beginning Regression Window.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141106071119
Gaia: aa63911ae979ed1e3eab2ba23a6e7d6a59085854
Gecko: 780af6b71bf2
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Triage: blocker.
Assignee: nobody → rlu
blocking-b2g: 2.1? → 2.1+
Should be a regression from bug 962434
Priority: P1 → P3
Dropping the priority on this from the FxA point of view since its not blocking our launch of FxA, still a problem for 2.1 though.
----------------------------------------------------
Regression Window B2G-Inbound (Shallow Flash)
----------------------------------------------------

Last Working:
Device: Flame 2.1
BuildID: 20140715074001
Gaia: 71cdbd38bc9321b53fa4d3004650512e871cc0d8
Gecko: 66700972e7af
Version: 33.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First Broken:
Device: Flame 2.1
BuildID: 20140715080714
Gaia: 2281a46cf77422068c3a8342e6a0950f2486d3a6
Gecko: d331085c63fd
Version: 33.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 71cdbd38bc9321b53fa4d3004650512e871cc0d8
Gecko: d331085c63fd

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 2281a46cf77422068c3a8342e6a0950f2486d3a6
Gecko: 66700972e7af

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/71cdbd38bc9321b53fa4d3004650512e871cc0d8...2281a46cf77422068c3a8342e6a0950f2486d3a6

Caused by Bug 962434
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 962434 ?  Bug is already assigned so holding off on NI to patch author
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: aalldredge
Is this affects v2.2?
Flags: needinfo?(rlu)
Duplicate of this bug: 1092314
Yes, this issue could be reproduced on v2.2.
Flags: needinfo?(rlu)
As a discussion with George, this issue could be fixed if we implement bug 911880, so dupe this one to that bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: trusted-window
See bug 911880 comment 6.
Status: RESOLVED → REOPENED
Flags: needinfo?(rlu)
Resolution: DUPLICATE → ---
Thanks for the advice, after a sync with Alive and George,
will try to brew a regression fix instead of relying on that refactor work.
Status: REOPENED → ASSIGNED
Flags: needinfo?(rlu)
Attached file Patch V1
WIP only, tests are not complete yet.

Alive,

Could you help take a look to confirm this is the right direction?
Thank you.
Attachment #8521253 - Flags: feedback?(alive)
Comment on attachment 8521253 [details] [review]
Patch V1

Vegeta!
Attachment #8521253 - Flags: feedback?(alive) → feedback+
Blocks: 1088604
No longer blocks: 1007956
Comment on attachment 8521253 [details] [review]
Patch V1

Patch updated as your suggestion.
Please help take a look if possible, and I'm going to add unit tests for this change.

Thank you.
Attachment #8521253 - Flags: feedback+ → feedback?(alive)
Comment on attachment 8521253 [details] [review]
Patch V1

Go!
Attachment #8521253 - Flags: feedback?(alive) → feedback+
Comment on attachment 8521253 [details] [review]
Patch V1

Patch updated with unit tests available.

Alive, could you help review this?
Thank you.
Attachment #8521253 - Attachment description: WIP → Patch V1
Attachment #8521253 - Flags: review?(alive)
Comment on attachment 8521253 [details] [review]
Patch V1

Thanks!
Attachment #8521253 - Flags: review?(alive) → review+
CI passed, master,
https://github.com/mozilla-b2g/gaia/commit/98824c64d3e6d0ae45b98ea754fa4e44d0c23a9d

--
Alive, thanks for the review.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8521253 [details] [review]
Patch V1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 962434
[User impact] if declined: Cannot create an FxA account during FxA Web flow.
[Testing completed]: Yes, manually and unit testing.
[Risk to taking this patch] (and alternatives if risky): Should be low, tried to minimize the affected aspect of the changes.
[String changes made]: N/A
Attachment #8521253 - Flags: approval-gaia-v2.1?
Verified the issue is fixed on 2.2 Master Flame

Year of Birth dropdown selection works

"Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
===================================================================
Leaving verifyme for 2.1 patch uplift
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8521253 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attached file Patch for v2.1
Need a specific patch for v2.1
Attached video 20141123001201.mp4
This issue has been successfully verified on Flame 2.1
See attachment: 20141123001201.mp4
Reproducing rate: 0/5

Flame 2.1 buid:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.