[Tako][Bluetooth] Fail to redial last outgoing call in call log by quick press the "call" button twice on Sony WM600 BTHF. as the last call log is incoming call in call log.

RESOLVED DUPLICATE of bug 1078921

Status

Firefox OS
Bluetooth
P1
critical
RESOLVED DUPLICATE of bug 1078921
4 years ago
4 years ago

People

(Reporter: johnhsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

Preconditios:
   Connect BT headset ( Sony WM600 ) to test phone1.

Test Steps:
1) Make a outgoing call from test phone1 to phone2 and answer this outgoing call 
   on phone2, then hang up this call.
2) Make a incoming call to test phone1 from phone3 and answer this incoming call 
   on test phone1, then hang up this call.
3) Open call log in Dialer, the last call should be incoming call phone3 number.
4) Quick press the "call" button twice on Sony WM600 BTHF to redial last outgoing 
    call.


Actual results:

Test Phone1 redial a incoming call phone3 number in call log.


Expected results:

Test Phone1 should redial a outgoing call phone2 number in call log.
(Reporter)

Comment 1

4 years ago
== Reproduce Rate ==
   100%

== Reproducible on Reference phone (Flame) ==
   Yes

== Build Information ==

Gaia         d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko        df0479fb8c18379488013452e903c33bca384b0d
BuildID      20140926012311
Version      32.0
Device Name  Tako
Severity: normal → critical
Priority: -- → P1
Please check bug 1078921. Patch already commit into v2.1. 
https://github.com/mozilla-b2g/gaia/commit/d21855db7efd500b7fd7a062cc2753f66337e819
Can you make sure you had the latest code?
Flags: needinfo?(johnhsu)
(Reporter)

Comment 4

4 years ago
Update BuildID to 20141023232304

Gaia         d056733f8a7a1a152f5458b323f092c47dbffa48
Gecko        df0479fb8c18379488013452e903c33bca384b0d
BuildID      20141023232304
Version      32.0
Flags: needinfo?(johnhsu)
(Reporter)

Comment 5

4 years ago
Hi Shawn,
I have modified dialer.js in communications/dialer app following bug#1078921, and re-test redial outgoing
call scenario. The result is normal. Thanks for your comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1078921
You need to log in before you can comment on or make changes to this bug.