Only retrieve outgoing calls for Bluetooth redial

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: josh, Assigned: rik)

Tracking

(Blocks: 1 bug)

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1070854 +++

CR: ALPS01734101
Repeat Steps:
[Init]
1.BT is powered off
[step]
1.pair with samsung sbh170
2.make a MT call,then make a MO call
3.long press redial key on SHB170 to redial the latest number 
[expect result]
can dial out the MO call
[error]
samsung sbh170 can only dial out the MT call(always)
[note]
SBH170&SHB9000 have this issue
compared with X2,X2 has no this issue

Analysis;
  From the main log, below log showed that HFP has callbacked with redial request. Telephony RD has commented that call has accepted successfully without entering alerting state. But HFP did not received phone state changed with active call more than 0.

  09-16 23:50:43.212   163  1249 D BTIF_HF : HAL bt_hf_callbacks->dial_call_cmd_cb
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1070854
Summary: [Woodduck][MT6572][MT6627][BT][HFP]Some devices can only dial out the MT call when test redial → Retrieve the last entry of outgoing call in the call history for Bluetooth redial
This looks like more a Bluetooth related issue than a front-end dialer problem. Moving the bug to the BT component.
Component: Gaia::Dialer → Bluetooth
We need to get the latest record of outgoing call. I'm not the gaia dev, but I checked call_log_db.js, it seems the type shall be 'dialing'.
I thought Bug 878184 already provided enough information, so I did provide clear context and make people confused, sorry about that.
Bluetooth Handsfree profile spec depicted that, "Last Number Re-Dial from the HF
The hansfree may initiate outgoing voice calls by recalling the last number dialed by the audio gateway(phone).", which means when Bluetooth handsfree send redial command to phone, phone shall redial the last entry of outgoing calls.
We used to argue with Bluetooth certification lab during FXOS v1.1 IOT phase, but eventually this is handsfree spec definition, we have to follow it, otherwise certification fails.
Flags: needinfo?(anthony)
We have clarification on bug 1070854. So I think we need a Dialer fix.
lastEntryDate.

    // Dialing from the call log
    // ATD>3 means we have to call the 3rd recent number.
    var position = isAtd ? parseInt(command.substring(4), 10) : 1;
    CallLogDBManager.getGroupAtPosition(position, 'lastEntryDate', true, null,
    function(result) {
      if (result && (typeof result === 'object') && result.number) {
        CallHandler.call(result.number);
(Assignee)

Updated

3 years ago
Flags: needinfo?(anthony)
Summary: Retrieve the last entry of outgoing call in the call history for Bluetooth redial → Only retrieve outgoing calls for Bluetooth redial
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
Component: Bluetooth → Gaia::Dialer
Target Milestone: --- → 2.1 S6 (10oct)
(Assignee)

Updated

3 years ago
Assignee: nobody → anthony
(Assignee)

Comment 7

3 years ago
Created attachment 8501047 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24887

I haven't tested this patch. Shawn: Could you give it a go?
Attachment #8501047 - Flags: review?(drs+bugzilla)
Flags: needinfo?(shuang)
Comment on attachment 8501047 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24887

I didn't test this, but it looks reasonable to me.
Attachment #8501047 - Flags: review?(drs+bugzilla) → review+
I have tested the patch. It looks good to me. Hopefully we can sync this patch to 2.0/2.0m/2.1. Otherwise, we probably cannot pass certification. Thanks for Anthony's help!
Flags: needinfo?(shuang)
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
(Assignee)

Comment 10

3 years ago
https://github.com/mozilla-b2g/gaia/commit/71a6d32f9a0c1dbce06cf3a191a67d046b9771f0
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
(Assignee)

Comment 11

3 years ago
Comment on attachment 8501047 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24887

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Bluetooth Certification 
[Testing completed]: New unit test. And manual testing by Shawn.
[Risk to taking this patch] (and alternatives if risky): Extremely low and easy to back out.
[String changes made]: None.
Attachment #8501047 - Flags: approval-gaia-v2.1?
Attachment #8501047 - Flags: approval-gaia-v2.0?
Comment on attachment 8501047 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24887

Can QA/reporter help with verification here?
Attachment #8501047 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+

Updated

3 years ago
Keywords: verifyme
(Reporter)

Updated

3 years ago
Blocks: 1080481
(Assignee)

Comment 14

3 years ago
Bahavana : There was also a 2.0 approval request :)
Flags: needinfo?(bbajaj)
Duplicate of this bug: 1083057
(In reply to Anthony Ricaud (:rik) from comment #14)
> Bahavana : There was also a 2.0 approval request :)

sry that was miss !

I am blocking on this given the certification impact and approving uplift for 2.0.
Flags: needinfo?(bbajaj)
Comment on attachment 8501047 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24887

can QA help verify this?
Attachment #8501047 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
The test changes need rebasing for v2.0.
Flags: needinfo?(anthony)
Keywords: branch-patch-needed
(Assignee)

Comment 19

3 years ago
v2.0: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
status-b2g-v2.0: affected → fixed
Flags: needinfo?(anthony)
Keywords: branch-patch-needed
(Reporter)

Comment 21

3 years ago
(In reply to bhavana bajaj [:bajaj] from comment #17)
> Comment on attachment 8501047 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/24887
> 
> can QA help verify this?

Hi Peipei,
PLease verify this bug on 2.0/2.0M/2.1/2.2? Thanks!
Flags: needinfo?(pcheng)
I tried with Jabra Talk and Jabra BT2045 (the only BT headset I have), but could not reproduce the problem mentioned in comment 0 on an old build 20141006040204. 
So I cannot verify now :(

Josh/Shawn, could you please confirm whether this is specific to some BT headset?
Flags: needinfo?(shuang)
Flags: needinfo?(pcheng)
Flags: needinfo?(jocheng)
You can have only an incoming call in the call history. Then do redial from Bluetooth headset. If you see it redials that incoming call phone number, that's the bug.
Flags: needinfo?(shuang)
The behavior on 2.0m/2.0/2.1/2.2 is: Bluetooth redial will redial the latest outgoing call. If no outgoing call, it will not redial.

Verified on following build.

Woodduck V2.0m
----------------------------------------------------------------------------------
Gaia-Rev        43d16612beb42ebfeb58a082155fdac2259d7191
Gecko-Rev       e7df4dde2d9dbedee942333d34eaea2afe32bebc
Build-ID        20141021141251
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1413872046
FW-Date         Tue Oct 21 14:14:25 CST 2014

Flame V2.2
----------------------------------------------------------------------------------
Gaia-Rev        dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/f2d7d694aae5
Build-ID        20141020160202
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141020.191321
FW-Date         Mon Oct 20 19:13:32 EDT 2014
Bootloader      L1TC00011880

Flame V2.1
---------------------------------------------------------------------------------
Gaia-Rev        3d9cc667f4e929861a9a77c41096bbf5a9c1bde0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/928b18f7d8ff
Build-ID        20141021161205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141021.193023
FW-Date         Tue Oct 21 19:30:32 EDT 2014
Bootloader      L1TC10011800

Flame V2.0
---------------------------------------------------------------------------------------
Gaia-Rev        63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/09b9387be5ad
Build-ID        20141020160201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141020.192240
FW-Date         Mon Oct 20 19:22:50 EDT 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
Flags: needinfo?(jocheng)
(Reporter)

Updated

3 years ago
Keywords: verifyme
Duplicate of this bug: 1094627
status-b2g-v2.0: fixed → verified
status-b2g-v2.0M: fixed → verified
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.