Closed Bug 1094844 Opened 6 years ago Closed 6 years ago

Use new keywords API in search service

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal
Points:
5

Tracking

()

RESOLVED FIXED
Firefox 40
Iteration:
40.2 - 27 Apr
Tracking Status
firefox40 --- fixed

People

(Reporter: mak, Assigned: mak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

it's currently using getURIForKeyword to check if the user is inserting a search keyword duplicate of a bookmarks keyword.

The problem is that editKeyword is synchronous, but I guess we could make it async, since it's only used by a command.

(honestly I'm not sure if that still makes sense, we could just decide a keywords priority in unified complete and let the user create dupes...)
Flags: qe-verify-
Flags: firefox-backlog+
Blocks: 1140395
No longer blocks: 1141547
/browser/components/search/content/engineManager.js (View Hg log or Hg annotations)

    line 127 -- if (bmserv.getURIForKeyword(alias.value))

see also bug 1148457
Summary: Use new Bookmarks.jsm API in search service → Use new keywords API in search service
Points: 3 → 5
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Iteration: --- → 40.1 - 13 Apr
Attached patch patch v1Splinter Review
This was easier than expected
Attachment #8590863 - Flags: review?(jaws)
Note, I tested this manually with in-content prefs, old prefs and old search ui.
Comment on attachment 8590863 [details] [diff] [review]
patch v1

Review of attachment 8590863 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/search/content/engineManager.xul
@@ +35,5 @@
>      <command id="cmd_movedown"
>               oncommand="gEngineManagerDialog.bump(-1);"
>               disabled="true"/>
>      <command id="cmd_editkeyword"
> +             oncommand="gEngineManagerDialog.editKeyword().catch(Cu.reportError);"

self-comment: I should use Components.utils rather than Cu.
Iteration: 40.1 - 13 Apr → 40.2 - 27 Apr
Attachment #8590863 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/75afd4419cd3
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
You need to log in before you can comment on or make changes to this bug.