Closed Bug 1095128 Opened 5 years ago Closed 5 years ago

Intermittent failures in add-ons manager mochitest-browser tests

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
Points:
3

Tracking

()

RESOLVED FIXED
mozilla36
Iteration:
36.3
Tracking Status
firefox34 --- fixed
firefox35 --- fixed
firefox36 --- fixed
firefox-esr31 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

Looks like bug 1080785 caused a surge of intermittent failures in various xpinstall tests. Worth looking at these as a group I think.
Flags: qe-verify-
Flags: firefox-backlog+
Iteration: 36.2 → 36.3
Not xpinstall at all, in fact three of these failures are all caused by the same problem
No longer blocks: 1000695, 1080785
Summary: Intermittent failures in xpinstall mochitest-browser tests → Intermittent failures in add-ons manager mochitest-browser tests
Blocks: 1000695
Attached patch patchSplinter Review
The test harness disables add-on updates so the background update running during tests doesn't mess things up. Unfortunately browser_bug557956.js opens the compatibility UI which has the side effect of turning add-on updates on so for most of the browser chrome tests add-on updates are enabled.

The four dependencies at least look to be caused by this, you can tell because for the period when background updates were broken by bug 1090450 they all stopped showing up.

I've just added a couple of the update prefs to those to be restored at the end of every run to make sure no other tests do this by accident.
Attachment #8524207 - Flags: review?(bmcbride)
Attachment #8524207 - Flags: review?(bmcbride) → review+
https://hg.mozilla.org/mozilla-central/rev/121a5cc63382
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.