Gaia not loading on current Mulet

RESOLVED FIXED in 2.1 S9 (21Nov)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gerard-majax, Assigned: gerard-majax)

Tracking

({regression})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

On current gecko/gaia master, mulet loads with an empty tab:
 - unable to change the URL
 - it's blocked on about:start
 - no content loaded
 - b2g shell.html not loaded as it should have been
Assignee

Comment 1

5 years ago
Reverting the pref changes from bug 1093691, my Mulet starts again.
Depends on: 1093691
Assignee

Updated

5 years ago
Keywords: regression
Assignee

Updated

5 years ago
Attachment #8518886 - Flags: review?(gavin.sharp)
Assignee

Updated

5 years ago
Comment on attachment 8518886 [details] [diff] [review]
Switch off e10s for Mulet

Review of attachment 8518886 [details] [diff] [review]:
-----------------------------------------------------------------

I think it's better in firefox.js if you add a && !defined (MOZ_MULET) to where we're setting that pref to true
(Unless the possibility of running Mulet using an e10s'fied version of Firefox is not in a distant future)
Assignee

Comment 6

5 years ago
(In reply to :Felipe Gomes from comment #5)
> (Unless the possibility of running Mulet using an e10s'fied version of
> Firefox is not in a distant future)

I have no idea on this, but I don't have any problem fixing it in firefox.js directly.
Assignee

Comment 7

5 years ago
Posted patch Switch off e10s for Mulet (obsolete) — Splinter Review
Assignee

Updated

5 years ago
Attachment #8518886 - Attachment is obsolete: true
Attachment #8518886 - Flags: review?(gavin.sharp)
Assignee

Updated

5 years ago
Attachment #8519015 - Flags: review?(gavin.sharp)
Comment on attachment 8518886 [details] [diff] [review]
Switch off e10s for Mulet

I think I prefer this patch, actually - removes the mulet stuff from firefox proper.
Attachment #8518886 - Flags: feedback+
Attachment #8519015 - Flags: review?(gavin.sharp) → review-
Attachment #8518886 - Attachment is obsolete: false
Whiteboard: [systemsfe]
Assignee

Updated

5 years ago
Attachment #8519015 - Attachment is obsolete: true
Assignee

Comment 9

5 years ago
Comment on attachment 8518886 [details] [diff] [review]
Switch off e10s for Mulet

Gavin, since you prefer this one :)
Attachment #8518886 - Flags: review?(gavin.sharp)
Attachment #8518886 - Flags: review?(gavin.sharp) → review+
Assignee

Comment 11

5 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #10)
> Pending try: https://tbpl.mozilla.org/?tree=Try&rev=4c67fd56445a

Green.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fac2cfed1419
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
You need to log in before you can comment on or make changes to this bug.