Closed Bug 1095653 Opened 7 years ago Closed 7 years ago

[Loop]Firefoxhello! when making a loop call with out permissions, results in an endless calling that is not seen by other user

Categories

(Firefox OS Graveyard :: Gaia::Loop, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1082517
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: rmitchell, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3])

Attachments

(1 file)

Description:
when making a loop call with out permissions, results in an endless calling that is not seen by other user


Repro Steps:
1) Update a Flame to 20141107001205
2) Launch loop for the first time with no permissions granted 
3) Make a loop call to any user 


Actual:
Endless call with other user uninformed 


Expected:
Call screen with and other user is informed of call 

Environmental Variables:
Device: Flame 2.1
Build ID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
See attached:logcat,video clip:https://www.youtube.com/watch?v=mAUsfVd3gMM
Flags: needinfo?(jmitchell)
This issue DOES not occur on  2.2 (319mb)(Kitkat Base)(Shallow Flash) flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
There is notification of no mic or camera, giving user ability to miss the endless call 

Flame 2.2
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107040206
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 64f4392d0bdc
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash
BuildID: 20141107000206
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 9836e9d81357
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regression
Blocks: 1036490
[Blocking Requested - why for this release]: regression, broken functionality, confusing UX
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring
Shell, another loop bug that I am requesting help for. Can you please help re-direct this bug to the right folks.
I think it'll help to have a regression window from QA and we should do necessary backouts depending on what the original culprit was.
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(sescalante)
Regression window
Last working
BuildID: 20140829122301
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: 9b3fbc370631
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140829123201
Gaia: c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df
Gecko: 2a354048f964
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: 007f3c50cf69f044628a23c2376c6d88aa45f617
Gecko: 2a354048f964
Broken Gaia / Working Gecko = Repro
Gaia: c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df
Gecko: 9b3fbc370631
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/007f3c50cf69f044628a23c2376c6d88aa45f617...c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df


B2G Inbound
Last working
BuildID: 20140828201159
Gaia: 7616583ebf507860ae22066e38a1205d311400ae
Gecko: 6d5984d94d81
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140828202701
Gaia: c0fa9fe2f91ea76191d4e7c58db1dbf2993f76c8
Gecko: 9e1d80308ac1
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: 7616583ebf507860ae22066e38a1205d311400ae
Gecko: 9e1d80308ac1
Broken Gaia / Working Gecko = Repro
Gaia: c0fa9fe2f91ea76191d4e7c58db1dbf2993f76c8
Gecko: 6d5984d94d81
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/7616583ebf507860ae22066e38a1205d311400ae...c0fa9fe2f91ea76191d4e7c58db1dbf2993f76c8
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by Bug 1054215 - can you take a look Kevin?
Blocks: 1054215
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
QA Contact: ckreinbring
It looks like the permissions window pops up, then the loop app immediately pops up afterwards, without waiting for the permission. It doesn't really look like bug 1054215 could have caused this bug, but I don't know enough to be sure. I need to talk to some loop engineers because I'm not exactly sure how this app works.
Flags: needinfo?(kgrandon)
Hey Cristian - I'm not too familiar with Loop here, could you help me debug this? My assumption is that we might need to wait for the permission before showing the calling screen.
Flags: needinfo?(crdlc)
Hi Kevin,

   Repo: https://github.com/mozilla-b2g/firefoxos-loop-client
   Go to branch master or 1.1

   Once you're in this branch please run |grunt build| in your console to install FXHello in your device (Setting > Developer > ADB and DevTools)

I started in Loop three weeks ago and I don't have the whole background needed, maybe Borja can help you with some advice here because he is here from the beginning.
Flags: needinfo?(crdlc) → needinfo?(borja.bugzilla)
This sounds like what was fixed in 2.0 with Bug 1007066 - The permission prompt appears below the attention screen.

Fred, you worked on that original bug - do you have any insight on when this might have gotten over-written?
Flags: needinfo?(sescalante) → needinfo?(gasolin)
previously I've prompt up permission screen z-index level to callscreen when they both exists, so user will see the permissions screen over callscreen
 https://github.com/mozilla-b2g/gaia/pull/19971/files

I saw in 2.1 the correspondent style has been changed, it might cause the previous patch not applied anymore.
Flags: needinfo?(gasolin)
I am not reproducing the issue in 2.1 FxOS with master loop branch. 

In this master loop branch, bug 1082517 was landed and I think this is the reason this issue is not happening anymore (see comment https://bugzilla.mozilla.org/show_bug.cgi?id=1082517#c23)

Before resolving the bug, setting ni to Massimo to verify that the issue is fixed.
Flags: needinfo?(mbarone976)
This issue is fixed in Fx Hello master branch (version b1e1edb) with FxOS 2.1
Thanks Massimo, resolving the bug as duplicated of bug 1082517.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1082517
Flags: needinfo?(mbarone976)
Flags: needinfo?(borja.bugzilla)
You need to log in before you can comment on or make changes to this bug.