[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

RESOLVED FIXED in seamonkey2.54

Status

RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: stefanh, Assigned: stefanh)

Tracking

SeaMonkey 2.54 Branch
seamonkey2.54

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 fixed, seamonkey2.54 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Tree rows are currently styled with the standard colors from tree.css, but tree rows in the Bookmarks Manager, MailNews and Address Book sidebars should be styled differently (like in Finder).
(Assignee)

Comment 1

4 years ago
Created attachment 8519583 [details] [diff] [review]
WIP

I decided to use a class for those 3 trees and style them in communicator.css instead of having 3 files to maintain. Should probably do the same with the splitter... This looks OK, I'm just a bit disturbed by the background-color of the tree header since it conflicts a bit the blue gradient of selected tree rows. Interestingly, the background-color of the tree headers (list views) look slightly different in native mac apps... it's not as soft as ours.
(Assignee)

Updated

a year ago
Summary: [Mac Classic] Finder-like tree rows in Bookmarks Manager, MailNews and Address Book sidebars → [Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists
(Assignee)

Comment 2

a year ago
Created attachment 8896636 [details] [diff] [review]
[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

OK, so this is the final version. Compared to the previous patch i haven't used used any additional classes - I just use what we currently have which means some code duplication.

When it comes to mailnews and address book, I don't change the font-weight like in BM - the reason for that is of course that it would mess up the usage of 'bold' as a symbol of new mail and account name. I realize now that I could chnage the font-size in address book - tell me if you think that would be appropiate (but maybe it's a bit inconsistent?). Think about it, atm I'm having trouble deciding what route to take here :-)

The new style require a inverted twisty and we currently don't have any means of getting that with native styling. The use of an svg image creates a side-effect: bug 1280812, which I work-around by setting a hard-coded width of the twisty (that's the "width: 16px;" in 3 places).
Attachment #8519583 - Attachment is obsolete: true
Attachment #8896636 - Flags: review?(frgrahl)
(Assignee)

Updated

a year ago
Duplicate of this bug: 1082690
(Assignee)

Updated

a year ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

a year ago
Hmm, I guess I could also skip the font-weight changes in the BM manager...
Comment on attachment 8896636 [details] [diff] [review]
[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

> Think about it, atm I'm having trouble deciding what route to take here :-)

All 3 look a little different when selected. For me under 10.12.6 the variant in the mail window is the most readable and matches Finder most closely. I would change all 3 to be consistent. Pick your favorite :)

Twisties looks fine to me.

r+ with selection made consistent.
Attachment #8896636 - Flags: review?(frgrahl) → review+
(Assignee)

Comment 6

a year ago
There's no difference between Address Book and MailNews - maybe you had the window over another background when checking? Amyway, give me a few days to think about this (there's also 10.9, which looks completely different - the selected bg color is a blue gradient there and there's no vibrancy at all) ;-)
> There's no difference between Address Book and MailNews

There is a nice Thunderstorm brewing here right now. Will recheck it later. Thought the font colow when selected was different.

FRG
> There's no difference between Address Book and MailNews - maybe you had the window over another background when checking? 

I tried again and the colors seem to be more muted in the address book even when the background is the same. Same for selection. Hard to say. Overall you are right. Nothing to be worth investigating. Or I might just need to need new glasses. Probably an illusion caused by the different words in the selection panes.

Comment 9

a year ago
Pushed by stefanh@inbox.com:
https://hg.mozilla.org/comm-central/rev/dfa8c31dafd8
[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists. r=frg.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Comment 10

a year ago
I took the route of making the BM manager behave the same as the rest. Will wait a day or two before asking approval for c-b and comm-esr52.
status-seamonkey2.54: --- → fixed
Version: Trunk → SeaMonkey 2.54 Branch
> Will wait a day or two before asking approval for c-b and comm-esr52.

Just do it now imho. 2.54 is in bad shape right now and no one will probably test it. When it is in comm-esr52 we can set the final csets for 2.49.1
Target Milestone: --- → seamonkey2.54
(Assignee)

Comment 12

a year ago
Comment on attachment 8896636 [details] [diff] [review]
[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

(In reply to Frank-Rainer Grahl (:frg) from comment #11)
> > Will wait a day or two before asking approval for c-b and comm-esr52.
> 
> Just do it now imho. 2.54 is in bad shape right now and no one will probably
> test it. When it is in comm-esr52 we can set the final csets for 2.49.1

Right, I don't see any recent Mac builds in https://archive.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/... I've actually tested this more on comm-esr52 (running a comm-esr52 build with the patch right now).


[Approval Request Comment]
Risk to taking this patch (and alternatives if risky): Low, CSS-changes only.
String changes made by this patch: None.
Attachment #8896636 - Flags: approval-comm-esr52?
Attachment #8896636 - Flags: approval-comm-beta?
(Assignee)

Updated

a year ago
Summary: [Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists → [Mac default] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists
> Right, I don't see any recent Mac builds 

There is only one builder left which is overwhelmed. The others play with the beachbunnies according to ewong. Tinderbox builds were still done last week.

I only tested on comm-esr52 so this should be a no brainer.
(Assignee)

Updated

a year ago
Summary: [Mac default] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists → [Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

Comment 14

a year ago
Comment on attachment 8896636 [details] [diff] [review]
[Mac Classic] Style left panes in Bookmarks Manager, MailNews and Address Book as source lists

a=me, thanks
Attachment #8896636 - Flags: approval-comm-esr52?
Attachment #8896636 - Flags: approval-comm-esr52+
Attachment #8896636 - Flags: approval-comm-beta?
Attachment #8896636 - Flags: approval-comm-beta+
https://hg.mozilla.org/releases/comm-beta/rev/70a707e6b868f1e328d05c28d5483e7fbff14537
https://hg.mozilla.org/releases/comm-esr52/rev/ba6b2ab5df8d265198aff3684d77fe8f26eab30f
status-seamonkey2.49esr: --- → fixed
status-seamonkey2.50: --- → wontfix
status-seamonkey2.51: --- → wontfix
status-seamonkey2.52: --- → wontfix
status-seamonkey2.53: --- → fixed
You need to log in before you can comment on or make changes to this bug.