Closed Bug 1096090 Opened 7 years ago Closed 7 years ago

Android Aurora 35 fails to play videos on Asus Memopad

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

35 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox36 unaffected, fennec35+)

RESOLVED WORKSFORME
Tracking Status
firefox36 --- unaffected
fennec 35+ ---

People

(Reporter: jan.manthay, Assigned: snorp)

Details

Attachments

(1 file)

Example:
http://www.tagesschau.de/ausland/katalanen-101.html

Beta 34 plays the video correct and with sound

Aurora 35 plays the video with grey, horizontal artifacts (like on an old tv without correct antenna position) and without sound.

Device is an Asus Memopad 7 HD (ME173X) with PowerVR SGX 544MP
Android 4.2.2
Aurora video playback uses MediaCodec (bug 1014614).

Can you confirm wether you see the same with Nightly?

Do you see any issues playing videos on my test-page? http://people.mozilla.org/~atrain/mobile/tests/media.html
Those patches are in beta too, but I don't know if any builds have actually gone out with those applied yet. I, too, would like to hear how it does with Nightly.
Flags: needinfo?(jan.manthay)
Ok.
I really did some crazy testing, with Beta, Aurora and Nightly on my two devices. I tested all files on the test site with all versions, and I got some interessting results, and also some crashes.

First the Asus
Asus Memopad 7 HD (ME173X) with PowerVR SGX 544MP
Android 4.2.2

On http://www.tagesschau.de/ausland/katalanen-101.html

Beta: OK
Aurora: video errors, no sound
Nightly: video errors, but sound OK

On  http://people.mozilla.org/~atrain/mobile/tests/media.html
(I count the files from top to bottom)

Beta:
1. Ok
2. First Crashed to Bug 932455 second try OK
3. Ok
4. Ok
5. Ok
6. Ok 
7. Ok

Aurora:
1. Ok
2. Nothing happend, could not open
3. Video errors
4. Ok
5. Always crashes to Bug 1091599
6. Video errors, no sound
7. Video errors, no sound

Nightly:
1. Ok
2. Video errors, but sound Ok
3. Video errors
4. Ok
5. Ok
6. Video errors, but sound Ok
7. Video errors, but sound Ok

Second device: 
Motorola Moto G (2012)
Model XT1032 Adreno 305
Android 4.4.4

On http://www.tagesschau.de/ausland/katalanen-101.html

Beta: Ok
Aurora: Video Ok, no sound
Nightly: Ok

On  http://people.mozilla.org/~atrain/mobile/tests/media.html
(I count the files from top to bottom)

Beta:
1. Ok
2. Ok
3. Ok
4. Ok
5. Ok
6. Ok (stuttering, but I thing it was a network issue)
7. Ok (stuttering, but I thing it was a network issue)

Aurora
1. Ok
2. Video Ok, no sound
3. Ok
4. Ok, but crashed to Bug 1091599 when I stoped the replay
5. Always crashed to Bug 1091599 right away
6. Video Ok, no sound
7. Video Ok, no sound, crashed to Bug 1091599 after a few seconds

Nightly 
1. Ok
2. Ok
3. Ok
4. Ok
5. Ok
6. Ok
7. Ok

Wow, that took me a while, but I hope it is helpful in a way.
Flags: needinfo?(jan.manthay)
Jan, could I get you to take a screenshot while playing one of the videos with the problem in Nightly? It looks like this specific device has a problem with the new video decoding backend.
Flags: needinfo?(jan.manthay)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #4)
> Jan, could I get you to take a screenshot while playing one of the videos
> with the problem in Nightly? It looks like this specific device has a
> problem with the new video decoding backend.

In case you aren't sure how to do that, you should be able to take a screenshot by holding down both volume buttons and the power button. You can then mail it yourself from the 'gallery' (or just attach it to this bug with Firefox).
I made a screenshot, but it is not always like on the picture, so I did a youtube video too:
https://www.youtube.com/watch?v=JpwQs1et210
Flags: needinfo?(jan.manthay)
Flags: needinfo?(daaku911)
Flags: needinfo?(daaku911)
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Summary: Android Aurora 35 fails to play videos on tagesschau.de → Android Aurora 35 fails to play videos on Asus Memopad
Assignee: nobody → snorp
tracking-fennec: ? → 35+
Looks like this is fixed in Aurora 36, I just tested on multiple sites.
Also all videos on the testsite are running OK and with sound.

But sadly the error made it into the beta 35, so I think it will go release next week with the problem?
Confirmed that this is resolved in Firefox Beta. https://support.mozilla.org/en-US/questions/1042528

Do we know what fixed this or just set WFM?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.