Adjust Loop server urls to include /v0 to avoid potential redirects

RESOLVED FIXED in Firefox 35

Status

Hello (Loop)
Client
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
mozilla36
Points:
1
Bug Flags:
in-moztrap -
qe-verify -

Firefox Tracking Flags

(firefox35 fixed, firefox36 fixed)

Details

(Whiteboard: [watch])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Currently the loop-server supports both '<serverUrl>' and '<serverUrl>/v0'.

We should switch to the /v0 version to avoid needing to handle redirects in the future.

The server team have said that once rooms is ready and stable, they'll likely set up redirects of '<serverUrl>' to '<serverUrl>/v0' ready for starting to work on v1.
See Also: → bug 1096233

Comment 1

4 years ago
Hi Alexis,

When is the server team ready for this change - so we know when to make the client change?  If it's in the future - just when is it planned :)

Hi Mark,
Is this a visible /vO or is it transparent to the user.
backlog: --- → Fx37?
Flags: needinfo?(standard8)
Flags: needinfo?(alexis+bugs)
Whiteboard: [watch]
There is no need to do any server change right now to support that, it should already be the case. All the APIs are available at /v0
Flags: needinfo?(alexis+bugs)
(Assignee)

Comment 3

4 years ago
No user visible impact for the url itself.

If we don't do this, it'll increase latency times, so I think we should just do this simple swap for 35.
backlog: Fx37? → Fx35?
Flags: needinfo?(standard8)
(Assignee)

Comment 4

4 years ago
Created attachment 8525912 [details] [diff] [review]
Adjust Loop server urls to include /v0 to avoid potential redirects.

I've run through some tests locally with the production server to check that desktop isn't broken. I've also run through local tests to check this works with running the loop-server locally. I didn't see any issues.
Attachment #8525912 - Flags: review?(mdeboer)
(Assignee)

Updated

4 years ago
Assignee: nobody → standard8
Iteration: --- → 36.3
Points: --- → 1
Target Milestone: --- → mozilla36
backlog: Fx35? → Fx35+
Priority: -- → P1
Comment on attachment 8525912 [details] [diff] [review]
Adjust Loop server urls to include /v0 to avoid potential redirects.

Review of attachment 8525912 [details] [diff] [review]:
-----------------------------------------------------------------

I really don't like the mixing of single and double quotes, but that ship has sailed I'm afraid...
Attachment #8525912 - Flags: review?(mdeboer) → review+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1059334
https://hg.mozilla.org/mozilla-central/rev/af6a0f0b1b6f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-firefox35: --- → affected
status-firefox36: --- → fixed
Flags: qe-verify-
Flags: in-moztrap-
Comment on attachment 8525912 [details] [diff] [review]
Adjust Loop server urls to include /v0 to avoid potential redirects.

Approval Request Comment
[Risks and why]: Loop code to avoid redirects on Loop URLs when the server updates land.
[String/UUID change made/needed]: none
Attachment #8525912 - Flags: approval-mozilla-aurora?
Attachment #8525912 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
status-firefox35: affected → fixed
You need to log in before you can comment on or make changes to this bug.