Update Loop mobile client to support Loop server urls with /v0 and avoid potential redirects

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: oteo, Assigned: borjasalguero)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

4 years ago
Currently the loop-server supports both '<serverUrl>' and '<serverUrl>/v0'.

We should switch to the /v0 version to avoid needing to handle redirects in the future.

The server team have said that once rooms is ready and stable, they'll likely set up redirects of '<serverUrl>' to '<serverUrl>/v0' ready for starting to work on v1.
(Reporter)

Updated

4 years ago
Depends on: 1025792
(Reporter)

Updated

4 years ago
See Also: → bug 1096229
(Reporter)

Updated

4 years ago
Blocks: 1088993
(Reporter)

Updated

4 years ago
Assignee: nobody → borja.bugzilla
Status: NEW → ASSIGNED
(Reporter)

Updated

4 years ago
Blocks: 1097495
No longer blocks: 1088993
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1106782
(Reporter)

Updated

4 years ago
No longer blocks: 1097495
(Reporter)

Comment 2

3 years ago
[Tracking Requested - why for this release]:
tracking-b2g: --- → backlog

Comment 3

7 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.