Closed Bug 1096343 Opened 8 years ago Closed 6 years ago

Firefox Developer Edition "General" pane always shows link "Start using Sync" in settings

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: pollti, Assigned: eoger, Mentored)

References

()

Details

(Keywords: good-first-bug, Whiteboard: [sync-ui-polish])

Attachments

(2 files)

Can we hide the link "Start using Sync" in Pref > General, when Sync is already in use?
Severity: normal → enhancement
But does the sync actually work? For me it does not and I want to mark this as a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1096905
How can I change the status to "CONFIRMED"?
Hi,
c1: I don't think that this id a dup of bug 1096905 - this is about a frontend suggestion, not about the functionallity (btw, Sync works for me).
c2: You can mark as CONFIRMED by choosing NEW.
This never happened for me in recent versions
(In reply to Tim (pollti) from comment #0)
> Can we hide the link "Start using Sync" in Pref > General, when Sync is
> already in use?

This link should not appear when sync is configured (and indeed, doesn't for me)  Can you see if the browser console has any messages that may be relevant?
Flags: needinfo?(pollti)
FDE's browser console says the following:
>Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Firefox%20Developer%20Edition/chrome.manifest'.
>Could not read chrome manifest 'file:///C:/Program%20Files%20(x86)/Firefox%20Developer%20Edition/browser/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
>1424534294647	Services.HealthReport.HealthReporter	WARN	No prefs data found.
Maybe the link still appears, because I didn't use the link "Start using Sync..." (I used [menu button] -> [Sign in to Sync])?
Flags: needinfo?(pollti)
Thanks for the update!

(In reply to Tim (pollti) from comment #6)
> FDE's browser console says the following:

Sadly none of that is relevant :(

> Maybe the link still appears, because I didn't use the link "Start using
> Sync..." (I used [menu button] -> [Sign in to Sync])?

It shouldn't matter how you configure sync - once you have all parts of the UI should change.

To verify, we are talking about the "Sync" pane of Preferences, right?  And even though you have configured sync and it is working, Sync Prefs still show "Sign into Sync", right?  Could you please attach a screen-shot?

And can you please also check the "hamburger" menu - there is a Sync area at the bottom - does it also say something like "Sign in to Sync", or is it just showing your email address (which is expected)?  Similarly, what does the the "Tools" menu say regarding Sync?  I'm trying to work out if is it *just* prefs that are wrong, or if the entire UI is.
Flags: needinfo?(pollti)
Looks like we're talking about different things then - I'm sorry for that. I'm talking about the link in about:preferences#general.
I attach a screenshot here, where the sync part is marked - it's a localized (German) FDE, but it should be simmilar for en-US.
I'm sorry for any inconvenience.
Flags: needinfo?(pollti)
Ah, right, my apologies - I see now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox Developer Edition always shows link "Start using Sync" in settings → Firefox Developer Edition "General" pane always shows link "Start using Sync" in settings
Seems to work now. I logged in to Sync and I don't see "Start using Sync" in General section from preferences. Should this be marked as resolved fixed or worksforme?
The link is still visible to me in current FDE here. Did you use the Aurora/FDE build?
Flags: needinfo?(andrei)
I can reproduce the bug and I see the link now. I'm using Firefox Developer Edition in en_US.

I did not see it since it is not present in Firefox Nightly. I can reproduce it only in Aurora/DevEdition.

I think this can be marked as fixed since it does not appear in Nightly.
Flags: needinfo?(andrei)
This link never existed in Fx Nightly. This code is only for FDE.
Ryan, I think we need UX help here. In DevEdition's about:preferences#general pane there is text "Tip: This uses separate profiles. Use Sync to share data between them. Start using Sync…" where "Start using Sync…" is a link that takes you to about:preferences#sync, and this is shown even when Sync is already configured.

The options I see are:
* Remove that entire line, including the "Tip: ..." part when Sync is configured - but removing the info about separate profiles doesn't sound right.
* Remove just the "Start using Sync…" part when Sync is configured - but keeping the text about Sync but removing a way to configure Sync doesn't sound right.
* Change the text to read "Tip: This uses separate profiles." and have the link portion be "Use Sync to share data between them…" - this would make the text somewhat neutral to the Sync state (ie, the text makes sense both when Sync is and isn't configured)
* Change the link portion from "Start using Sync…" to, eg, "Configure Sync…" when Sync is already configured.
* Change the link portion from "Start using Sync…" to, eg, "Configure Sync…" unconditionally (ie, making the link text more neutral WRT Sync is or isn't configured).

but you may have a completely different idea...
Flags: needinfo?(rfeeley)
Just checked as I wasn't sure, but "Start using Sync…" takes the user to FxA.Sync login. i.e. about:accounts?action=signin&entrypoint=dev-edition-setup

I don't think we have a translated string for "Configure Sync…" handy, but can use what we are using in other parts of the browser.

CURRENT WITH AND W/O SYNC
[x] Allow Firefox Developer Edition and Firefox to run at the same time
    Tip: This uses separate profiles. Use Sync to share data between them. "Start using Sync…" (opens FxA.Sync login in a new tab)

PROPOSED W/O SYNC
[x] Allow Firefox Developer Edition and Firefox to run at the same time
    Tip: This uses separate profiles. Use Sync to share data between them. "Sign in to Sync…" (opens to FxA.Sync login in a new tab)

PROPOSED WITH SYNC
[x] Allow Firefox Developer Edition and Firefox to run at the same time
    Tip: This uses separate profiles. Use Sync to share data between them. "Open Sync preferences" (opens about:preferences#sync in same tab)

Make sense?
Flags: needinfo?(rfeeley) → needinfo?(markh)
Flags: needinfo?(markh) → firefox-backlog+
Version: 35 Branch → unspecified
Let's call this a Sync bug so it's more likely to get attention.
Component: Preferences → Sync
Mentor: markh
Keywords: good-first-bug
Priority: -- → P3
Whiteboard: [sync-ui-polish]
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Comment on attachment 8850671 [details]
Bug 1096343 - Use a different sync link in dev edition main preferences.

https://reviewboard.mozilla.org/r/123220/#review127478

Looks great, thanks.

::: browser/components/preferences/in-content/main.js:123
(Diff revision 1)
>        OS.File.stat(ignoreSeparateProfile).then(() => separateProfileModeCheckbox.checked = false,
>                                                 () => separateProfileModeCheckbox.checked = true);
> +
> +      fxAccounts.getSignedInUser().then(data => {
> +        document.getElementById("getStarted").selectedIndex = data ? 1 : 0;
> +      });

Unlikely to ever get hit in practice, but I think a final .catch(Cu.reportError) can't hurt here.
Attachment #8850671 - Flags: review?(markh) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s d8662bbcd9bd -d 2015c1f2ce57: rebasing 386079:d8662bbcd9bd "Bug 1096343 - Use a different sync link in dev edition main preferences. r=markh" (tip)
merging browser/components/preferences/in-content-old/main.js and browser/components/preferences/in-content/main.js to browser/components/preferences/in-content-old/main.js
merging browser/components/preferences/in-content-old/main.xul and browser/components/preferences/in-content/main.xul to browser/components/preferences/in-content-old/main.xul
merging browser/components/preferences/in-content/main.js
merging browser/components/preferences/in-content/main.xul
merging browser/locales/en-US/chrome/browser/preferences-old/main.dtd and browser/locales/en-US/chrome/browser/preferences/main.dtd to browser/locales/en-US/chrome/browser/preferences-old/main.dtd
warning: conflicts while merging browser/components/preferences/in-content/main.js! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94c77723eead
Use a different sync link in dev edition main preferences. r=markh
https://hg.mozilla.org/mozilla-central/rev/94c77723eead
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Comment on attachment 8850671 [details]
Bug 1096343 - Use a different sync link in dev edition main preferences.

This patch only changed browser/components/preferences/in-content but not browser/components/preferences/in-content-old. Please see https://mail.mozilla.org/pipermail/firefox-dev/2017-March/005211.html for more information.
Attachment #8850671 - Flags: review-
Backout: https://hg.mozilla.org/mozilla-central/rev/e544797fe9e9
Status: RESOLVED → REOPENED
Flags: needinfo?(eoger)
Resolution: FIXED → ---
Sorry about this, here is the patch applied to both folders.
Flags: needinfo?(eoger)
Comment on attachment 8850671 [details]
Bug 1096343 - Use a different sync link in dev edition main preferences.

https://reviewboard.mozilla.org/r/123220/#review128182

Thanks for the quick turn-around. Just a drive-by nit below, though since markh was fine with it I can go either way.

::: browser/locales/en-US/chrome/browser/preferences-old/main.dtd:43
(Diff revision 4)
>  <!ENTITY isDefault.label                  "&brandShortName; is currently your default browser">
>  <!ENTITY isNotDefault.label               "&brandShortName; is not your default browser">
>  
>  <!ENTITY separateProfileMode.label        "Allow &brandShortName; and Firefox to run at the same time">
>  <!ENTITY useFirefoxSync.label             "Tip: This uses separate profiles. Use Sync to share data between them.">
> -<!ENTITY getStarted.label                 "Start using Sync…">
> +<!ENTITY getStarted.notlogged.label       "Sign in to &syncBrand.shortName.label;…">

nit, can you use "getStarted.notloggedin.label" instead of "notlogged" ?
Attachment #8850671 - Flags: review?(jaws) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s ed78c071a907 -d f0d0fa452659: rebasing 386247:ed78c071a907 "Bug 1096343 - Use a different sync link in dev edition main preferences. r=jaws,markh" (tip)
merging browser/components/preferences/in-content/main.xul
merging browser/locales/en-US/chrome/browser/preferences/main.dtd
warning: conflicts while merging browser/components/preferences/in-content/main.xul! (edit, then use 'hg resolve --mark')
warning: conflicts while merging browser/locales/en-US/chrome/browser/preferences/main.dtd! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/197c71a71466
Use a different sync link in dev edition main preferences. r=jaws,markh
https://hg.mozilla.org/mozilla-central/rev/197c71a71466
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.