Closed Bug 1096538 Opened 5 years ago Closed 5 years ago

[Edit Mode] Thick blue line is displayed when long pressing app icons in edit mode

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: smiko, Assigned: cwiiis)

References

()

Details

(Keywords: regression, Whiteboard: [2.2-Daily-Testing] [systemsfe])

Attachments

(3 files)

Attached file Blue.txt
Description: When long pressing app icons in edit mode, a thick blue line is displayed at the top of the screen. 

Repro Steps:
1: Update a Flame to 20141110040206.
2: Long press an app icon to enter edit mode.
3: While in edit mode, long press an app.

Actual: A thick blue line is displayed at the top of the screen.

Expected: A blue line is not displayed. 

Device: Flame 2.2 (319mb/shallow flash)
BuildID: 20141110040206
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Gonk: --- shallow flash
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5

See attached: logcat

Video clip: http://youtu.be/JOQtO8CGmwE
This issue does NOT occur on Flame 2.1 (319mb/shallow flash). 

Actual result: A blue line is not displayed. 

Device: Flame 2.1
BuildID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

_______________________________________________________________________________________________________________

This issue DOES repro on Friday's Flame 2.2 (319mb/shallow flash)

Actual result: A blue line is displayed. 

Device: Flame 2.2
BuildID: 20141107073659
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: b62ccf3228ba
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing] [systemsfe]
Nominating as this is a pretty visible UI regression.
blocking-b2g: --- → 2.2?
Requesting a window.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141103022233
Gaia: 22d918d469725546ab5a28c5c9b94f78877d1b87
Gecko: 62eda4197b3d
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141103023733
Gaia: 22fd0ab3090300972a0ff8c7a08f4ed31f00eeb1
Gecko: 7a27ae9848b4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 22fd0ab3090300972a0ff8c7a08f4ed31f00eeb1
Gecko: 62eda4197b3d

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 22d918d469725546ab5a28c5c9b94f78877d1b87
Gecko: 7a27ae9848b4

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/22d918d469725546ab5a28c5c9b94f78877d1b87...22fd0ab3090300972a0ff8c7a08f4ed31f00eeb1

Caused by bug 1078766.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by bug 1078766 - can you take a look Chris
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(chrislord.net)
QA Contact: pcheng
argh, my bad, this only happens when app-grouping is disabled I think - holding off on this in case bug 1082675 lands soon.
Depends on: 1082675
Flags: needinfo?(chrislord.net)
(In reply to Chris Lord [:cwiiis] from comment #7)
> argh, my bad, this only happens when app-grouping is disabled I think -
> holding off on this in case bug 1082675 lands soon.

Is this a wontfix now?
Flags: needinfo?(chrislord.net)
Yeah, bug 1082675 has landed and appears to have stuck... I still need to check that this doesn't happen when dragging icons in collections though.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
This does indeed affect collections, but it seems collections has other issues too - it's pretty easy to break them now, and this is likely my fault...

Looking into fixing this.
Blocks: 1102119
Attachment #8525999 - Flags: review?(kgrandon)
Attachment #8525999 - Flags: review?(crdlc)
Attachment #8525999 - Flags: review?(kgrandon) → review+
If you have time to try to add a test around disable-sections it would be good. A marionette test might be quite tricky, but maybe a unit test or two would be good.
Comment on attachment 8525999 [details] [review]
Fix collection regressions caused by app-grouping

LGTM, could you add a comment about what "disable-sections" means in the script.js file. And also a small test here https://github.com/mozilla-b2g/gaia/blob/master/apps/sharedtest/test/unit/elements/gaia_grid/gaia_grid_test.js#L35? thanks a lot
Attachment #8525999 - Flags: review?(crdlc) → review+
blocking-b2g: 2.2? → 2.2+
I've pushed to the branch with added comment, unit test and marionette test - I've not tested the latter of those three because for whatever reason, marionette tests aren't working for me locally... So I'll wait on the try result coming back before flagging this again.

Note, I took out the w/ grouping unit test, as that attribute is no longe used.
Target Milestone: --- → 2.1 S9 (21Nov)
Comment on attachment 8525999 [details] [review]
Fix collection regressions caused by app-grouping

Addressed review comments, flagging to confirm this is ok. Marionette tests started working for me again today, so verified locally it works.
Attachment #8525999 - Flags: review?(kgrandon)
Attachment #8525999 - Flags: review?(crdlc)
Attachment #8525999 - Flags: review+
Comment on attachment 8525999 [details] [review]
Fix collection regressions caused by app-grouping

Test looks good to me, I think the R+ should still stand here. I'll go ahead and clear the request on Cristian to save him some cycles - unless he's already looked :) Thanks!
Attachment #8525999 - Flags: review?(kgrandon)
Attachment #8525999 - Flags: review?(crdlc)
Attachment #8525999 - Flags: review+
Merged: https://github.com/mozilla-b2g/gaia/commit/905829c6085ec693bdffaad3d751eab3a5085b40
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
On the current 2014-11-25 build, this issue appears to be fixed.  However, I am not certain that this issue is completely fixed as the blue bar will still appear near the top of the screen when dragging an app to the top and creating a new column.  See video for a visual aid https://www.youtube.com/watch?v=66S7B3bFQFc.

Please let me know if this issue is fixed, and if I should file a new bug.
Flags: needinfo?(chrislord.net)
(In reply to cnelson from comment #18)
> On the current 2014-11-25 build, this issue appears to be fixed.  However, I
> am not certain that this issue is completely fixed as the blue bar will
> still appear near the top of the screen when dragging an app to the top and
> creating a new column.  See video for a visual aid
> https://www.youtube.com/watch?v=66S7B3bFQFc.
> 
> Please let me know if this issue is fixed, and if I should file a new bug.

This is intended behaviour (see the spec in bug 1067435). It's just not meant to happen in collections.
Flags: needinfo?(chrislord.net)
This issue is verified fixed on Flame 2.2

The blue bar doesn't appear at the top of the screen when tapping and holding down on an application in edit mode.  

Flame 2.2

Device: Flame 2.2  (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141126040207
Gaia: 41b7be7c67167f367c3c4982ff08651d55455373
Gecko: 7bcc6573d204
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.