Regressions in smart collection edit mode

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kgrandon, Unassigned)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Reporter

Description

5 years ago
Seems we have a few regressions in the edit mode of smart collections, this is likely due to app grouping landing, and forgetting to check the impact on smart collections. The few things I noticed:

1 - You can create additional "groups" with dragging icons.
2 - You can drag icons from the pinned section down into the static section (and you should not be able to do this).
3 - A blue bar appears above the pinned section during a drag.

Fixing these seem like it might be complex. Perhaps the smart collection code should implement its own drag drop library, or we could abstract out the common bits from the grid view class.
Reporter

Updated

5 years ago
blocking-b2g: --- → 2.2?
Keywords: regression
I'm fixing this as part of bug 1096538 - the fix isn't particularly complicated, but we should think of how best to tidy up all this code soon...
Depends on: 1096538
blocking-b2g: 2.2? → 2.2+
This should be fixed after bug 1096538, please re-open if I missed anything.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Comment 3

5 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=1096538#c19.  According to comment #19 on the bug link provided, the description in comment 0 on this bug is intended functionality.

Should I close as invalid, or resolve as verified fixed?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Reporter

Comment 4

5 years ago
No, the description states that this relates to collections, not the home screen grid. It's definitely not invalid.

Comment 5

5 years ago
This issue is verified fixed on Flame 2.2.

No blue bar appears above the pinned section during a drag.

Additional groups will not be created during a drag, and the user cannot drag an icon from the pinned section into the static section.

Flame 2.2

Device: Flame 2.2  (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141126040207
Gaia: 41b7be7c67167f367c3c4982ff08651d55455373
Gecko: 7bcc6573d204
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)

Updated

5 years ago
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.