MPEG4Extractor ignores the initial track fragment decode time block

RESOLVED FIXED in mozilla36

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

Tracking

(Blocks: 1 bug)

29 Branch
mozilla36
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8520356 [details] [diff] [review]
Fix start times

We parse these into mTrackFragmentData, but only ever adjust mCurrentTime when we encounter the second one.

Just setting mCurrentTime directly seems to work and is much simpler.

This was affecting playback with the dashif player, where the first segment after we change resolutions would get the wrong playback times.
Attachment #8520356 - Flags: review?(ajones)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1096184
Attachment #8520356 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/534f1eb6d708
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.