RequestVideoData with aSkipToNextKeyframe=true can block forever

RESOLVED DUPLICATE of bug 1096752

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1096752
4 years ago
4 years ago

People

(Reporter: mattwoodrow, Unassigned)

Tracking

29 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'm hitting this sometimes on the dashif player.

If we call RequestVideoData with aSkipToNextKeyframe=true right at the end of one decoder, then we can block forever waiting for more data to be added (which won't ever happen).

Stack: http://pastebin.mozilla.org/7221998
(Reporter)

Comment 1

4 years ago
I believe this happened because bug 1096752 was giving us incorrect timestamps for our decoded frames. It no longer happens with that fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096752
You need to log in before you can comment on or make changes to this bug.