Array.isArray(new Proxy([], {})) should be false

RESOLVED DUPLICATE of bug 1111785

Status

()

Core
JavaScript: Standard Library
RESOLVED DUPLICATE of bug 1111785
4 years ago
3 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
ScriptedDirectProxyHandler needs an objectClassIs trap to fix this.  (It actually needs one to handle revoked proxies correctly, independent of this issue.)

Comment 1

4 years ago
Jeff: A DXR link and and a general outline of the fix turns this in to a great first bug.
Flags: needinfo?(jwalden+bmo)

Updated

4 years ago
Blocks: 978228

Comment 2

4 years ago
Relevant discussion thread on es-discuss: <https://esdiscuss.org/topic/array-isarray-new-proxy-should-be-false-bug-1096753>
This bug should await TC39 discussing the spec issue next week.

/be
(Reporter)

Comment 4

3 years ago
es-discuss went ahead and made this into a more full-blown thing with property-gets, a canonical symbol, and a bit more.  It's all rather more than seems to fit a mentored bug, at this point.  (Tho it'd work fine for someone half a dozen patches into SpiderMonkey development, far enough to have a sense of SpiderMonkey idioms and such.)
Mentor: jwalden+bmo
Flags: needinfo?(jwalden+bmo)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1111785
You need to log in before you can comment on or make changes to this bug.