e10s lockup when starting browser with lots of tabs

RESOLVED DUPLICATE of bug 1093693

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1093693
3 years ago
3 years ago

People

(Reporter: Nikolay Martynov, Unassigned)

Tracking

(Blocks: 1 bug)

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141110182958

Steps to reproduce:

I have a session with two windows and lots of tabs on them (~20-30). When I start up forefox-nightly (today's, 10 Nov 2014) e10s gets enabled and all my tabs get underscores in their names.

I use ctrl+pageup to go over all tabs and start their load.


Actual results:

It takes some time (couple of mins) and 'enter password to unlock your secutiry device' dialog appears. Several seconds after that browser completely locks up - I cannot finish entring my password.

When this happens I see this in console:

2014-11-10 21:47:29: stackwalker.cc:125: INFO: Couldn't load symbols for: /lib/x86_64-linux-gnu/libpthread.so.0|4D2C66FE147B80EE4E0C1902FB55218A0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322e9248
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f327dabe0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x50f53
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec170
2014-11-10 21:47:29: stackwalker.cc:125: INFO: Couldn't load symbols for: /usr/lib/firefox-trunk/libnspr4.so|A778040691C3055D3F5955ABA3910ADB0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6060
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322f94a0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6060
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x3e6a11b
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec1a0
2014-11-10 21:47:29: stackwalker.cc:125: INFO: Couldn't load symbols for: /usr/lib/firefox-trunk/libxul.so|86979354F2B1C3E44EA7CC0A29FECC9B0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec1d0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0xffffffff5d4d9ff6
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0xffa6
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0xffffffff
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec1d0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158750
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6060
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec230
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec210
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec2e0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec290
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec250
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6100
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec380
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec250
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec228
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158750
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158600
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a1587e0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f086a5530
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec2f0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x15
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec290
2014-11-10 21:47:29: stackwalker.cc:125: INFO: Couldn't load symbols for: |
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158750
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158600
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a1587e0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f086a5530
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158720
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a158600
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0a1587e0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f086a5530
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0b0fef48
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0b0fef40
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6060
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec350
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec310
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec310
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec380
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f0b0fef40
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322b6060
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f322f94a0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f14439200
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7f1f25047bf8
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec380
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec370
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec418
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec3e0
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec4fc
2014-11-10 21:47:29: basic_code_modules.cc:88: INFO: No module at 0x7fff201ec4d4

GDB's backtrace from 'master' firefox process:

#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f1f5d4d2f20 in PR_WaitCondVar (cvar=0x7f1f322e9240, timeout=4294967295)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/nsprpub/pr/src/pthreads/ptsynch.c:385
#2  0x00007f1f58610d12 in Wait (this=0x7f1f322f94a8, aInterval=<optimized out>) at ../../dist/include/mozilla/CondVar.h:79
#3  mozilla::Monitor::Wait (this=0x7f1f322f94a0, aInterval=aInterval@entry=4294967295) at ../../dist/include/mozilla/Monitor.h:40
#4  0x00007f1f587eb18e in mozilla::ipc::MessageChannel::WaitForSyncNotify (this=this@entry=0x7f1f322b6060)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:1305
#5  0x00007f1f587f06da in mozilla::ipc::MessageChannel::SendAndWait (this=this@entry=0x7f1f322b6060, aMsg=aMsg@entry=
    0x7f1f0b0fef40, aReply=aReply@entry=0x7fff201ec380)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:755
#6  0x00007f1f587f182e in mozilla::ipc::MessageChannel::Send (this=0x7f1f322b6060, aMsg=0x7f1f0b0fef40, 
    aReply=aReply@entry=0x7fff201ec380) at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:688
#7  0x00007f1f588cc6cc in mozilla::jsipc::PJavaScriptParent::SendGet (this=this@entry=0x7f1f25047bf8, objId=@0x7fff201ec418: 8, 
    receiver=..., id=..., rs=rs@entry=0x7fff201ec4fc, result=result@entry=0x7fff201ec4d4)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/obj-x86_64-linux-gnu/ipc/ipdl/PJavaScriptParent.cpp:432
#8  0x00007f1f5892fa03 in mozilla::jsipc::JavaScriptBase<mozilla::jsipc::PJavaScriptParent>::SendGet (this=0x7f1f25047be0, 
    objId=..., receiverVar=..., id=..., rs=0x7fff201ec4fc, result=0x7fff201ec4d4)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/ipc/JavaScriptBase.h:164
#9  0x00007f1f58932df9 in mozilla::jsipc::WrapperOwner::get (this=0x7f1f25047be0, cx=0x7f1f5db601a0, proxy=..., receiver=..., 
    id=..., vp=...) at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/ipc/WrapperOwner.cpp:402
#10 0x00007f1f5a138eaa in js::Proxy::get (cx=0x7f1f5db601a0, proxy=..., receiver=..., id=..., vp=...)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/src/proxy/Proxy.cpp:317
#11 0x00007f1f5a13c87a in getGeneric (vp=..., id=..., receiver=..., obj=..., cx=0x7f1f5db601a0)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/src/vm/NativeObject.h:1387
#12 get (vp=..., id=..., receiver=..., proxy=..., cx=0x7f1f5db601a0, this=<optimized out>)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/src/proxy/DirectProxyHandler.cpp:234
#13 js::CrossCompartmentWrapper::get (this=<optimized out>, cx=0x7f1f5db601a0, wrapper=..., receiver=..., id=..., vp=...)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/src/proxy/CrossCompartmentWrapper.cpp:172
#14 0x00007f1f5a138eaa in js::Proxy::get (cx=0x7f1f5db601a0, proxy=..., receiver=..., id=..., vp=...)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/js/src/proxy/Proxy.cpp:317
#15 0x00007f1f3245bff6 in ?? ()
#16 0x0000000000000000 in ?? ()


GBD's back track from 'Web content' process:

#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fd7edeeff20 in PR_WaitCondVar (cvar=0x7fd7e3a02780, timeout=4294967295)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/nsprpub/pr/src/pthreads/ptsynch.c:385
#2  0x00007fd7f0621d12 in Wait (this=0x7fd7e5ffa9a8, aInterval=<optimized out>) at ../../dist/include/mozilla/CondVar.h:79
#3  mozilla::Monitor::Wait (this=0x7fd7e5ffa9a0, aInterval=aInterval@entry=4294967295) at ../../dist/include/mozilla/Monitor.h:40
#4  0x00007fd7f07fc18e in mozilla::ipc::MessageChannel::WaitForSyncNotify (this=this@entry=0x7fd7e5f7cc90)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:1305
#5  0x00007fd7f0803017 in WaitForInterruptNotify (this=0x7fd7e5f7cc90)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:1315
#6  mozilla::ipc::MessageChannel::Call (this=this@entry=0x7fd7e5f7cc90, aMsg=<optimized out>, aReply=aReply@entry=0x7fffff5259b0)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:821
#7  0x00007fd7f0909826 in mozilla::plugins::PPluginModuleChild::CallNPN_GetValue_WithBoolReturn (this=0x7fd7e5f7cc30, 
    aVariable=@0x7fffff525a2c: NPNVSupportsXEmbedBool, aError=aError@entry=0x7fffff525a3e, aBoolVal=aBoolVal@entry=0x7fffff525a3d)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/obj-x86_64-linux-gnu/ipc/ipdl/PPluginModuleChild.cpp:253
#8  0x00007fd7f13aac8e in mozilla::plugins::child::_getvalue (aNPP=0x7fd7e3a061d8, aVariable=NPNVSupportsXEmbedBool, 
    aValue=0x7fffff525c08) at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/dom/plugins/ipc/PluginModuleChild.cpp:1131
#9  0x00007fd7e2a71159 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#10 0x00007fd7f13a9bda in mozilla::plugins::PluginModuleChild::AnswerPPluginInstanceConstructor (this=0x7fd7e5fde800, 
    aActor=0x7fd7e3a06170, aMimeType=..., aMode=@0x7fffff525d00: 1, aNames=..., aValues=..., rv=0x7fffff525d02)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/dom/plugins/ipc/PluginModuleChild.cpp:2025
#11 0x00007fd7f0906534 in mozilla::plugins::PPluginModuleChild::OnCallReceived (this=this@entry=0x7fd7e5fde800, __msg=..., 
    __reply=@0x7fffff525d80: 0x0)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/obj-x86_64-linux-gnu/ipc/ipdl/PPluginModuleChild.cpp:1071
#12 0x00007fd7f0801284 in mozilla::ipc::MessageChannel::DispatchInterruptMessage (this=0x7fd7e5fde860, aMsg=..., 
    stackDepth=<optimized out>) at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:1171
#13 0x00007fd7f0803496 in mozilla::ipc::MessageChannel::OnMaybeDequeueOne (this=0x7fd7e5fde860)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/glue/MessageChannel.cpp:1033
#14 0x00007fd7f07efc59 in MessageLoop::RunTask (this=0x7fffff527220, task=0x7fd7e5f506d0)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_loop.cc:361
#15 0x00007fd7f07f476c in MessageLoop::DeferOrRunPendingTask (this=<optimized out>, pending_task=...)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_loop.cc:369
#16 0x00007fd7f07f4883 in MessageLoop::DoWork (this=0x7fffff527220)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_loop.cc:447
#17 0x00007fd7f07ee2a6 in base::MessagePumpForUI::HandleDispatch (this=0x7fd7e5f4d460)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_pump_glib.cc:261
#18 0x00007fd7f07ee2e0 in (anonymous namespace)::WorkSourceDispatch (source=<optimized out>, unused_func=<optimized out>, 
    unused_data=<optimized out>)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_pump_glib.cc:106
#19 0x00007fd7ebf4ce04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fd7ebf4d048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fd7ebf4d0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fd7f07ede31 in base::MessagePumpForUI::RunWithDispatcher (this=0x7fd7e5f4d460, delegate=<optimized out>, 
    dispatcher=<optimized out>)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_pump_glib.cc:192
#23 0x00007fd7f07efcc4 in RunHandler (this=0x7fffff527220)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_loop.cc:226
#24 MessageLoop::Run (this=this@entry=0x7fffff527220)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/chromium/src/base/message_loop.cc:200
#25 0x00007fd7f1a3c317 in XRE_InitChildProcess (aArgc=<optimized out>, aArgv=<optimized out>)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/toolkit/xre/nsEmbedFunctions.cpp:550
#26 0x00007fd7f48f87a5 in content_process_main (argc=9, argv=0x7fffff527508)
    at /build/buildd/firefox-trunk-36.0~a1~hg20141110r214851/ipc/app/../contentproc/plugin-container.cpp:158
#27 0x00007fd7ef344ec5 in __libc_start_main (main=0x7fd7f48f85d7 <main(int, char**)>, argc=10, argv=0x7fffff527508, 
    init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffff5274f8) at libc-start.c:287
#28 0x00007fd7f48f8688 in _start ()


I can reliably reproduce this issue so I would be happy to do any additional testing or get any additional debuggning information if required.


Expected results:

Browser should not lock up. When I disable e10s nothing like this happens.
I thought this would be bug 1096013, but looking at the stacks, it looks more like a plugin deadlock. billm, I remember you talking about deadlock work during triage... is there a bug there to dupe this to?
Flags: needinfo?(wmccloskey)
This is actually a plugin hang. Bug 1093693 should fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wmccloskey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1093693
You need to log in before you can comment on or make changes to this bug.