Bug 1063169 (e10s-perf)

tracking performance issues with e10s

REOPENED
Unassigned

Status

()

defect
REOPENED
5 years ago
10 months ago

People

(Reporter: jimm, Unassigned)

Tracking

(Depends on 29 bugs, {meta})

Trunk
x86_64
Windows 7
Points:
---
666365, 1071411, 1117253, 1118086, e10s-nofxcpows, 1135719, 1162679, 1171720, 1176007, 1180916, 1181333, 1185788, 1213432, 1225476, 1233585, 1234565, 1242969, 1245793, 1250350, 1251939, 1252030, 1252768, 1254081, 1254088, 1254628, 1256133, 1318939, 972423, 1008435, 1019560, 1022988, 1027967, 1028859, 1037179, 1041161, 1047654, 1062713, 1065059, 1066342, 1066531, 1067084, 1067135, 1067236, 1067523, 1071868, 1073664, 1074971, 1074992, 1076820, 1080152, 1080884, 1080916, 1085032, 1093057, 1095020, 1095729, 1095778, 1096013, 1096076, 1096754, 1096756, 1097580, 1099406, 1099490, 1100340, 1101182, 1102926, 1103094, 1105891, 1107793, 1108538, 1109338, 1109364, 1109654, 1109875, 1110024, 1110503, 1113735, 1114355, 1126464, 1128056, 1130051, 1130443, 1133928, 1144120, 1144345, 1152453, 1152543, 1154877, 1156591, 1156592, 1157941, 1158111, 1160058, 1160831, 1161166, 1161798, 1162392, 1164014, 1166132, 1166881, 1170609, 1171173, 1171653, 1174239, 1174461, 1174767, 1174770, 1174771, 1174772, 1174776, 1174792, 1175477, 1175794, 1175940, 1176011, 1176019, 1178353, 1179732, 1179733, 1179735, 1181074, 1182405, 1182636, 1182637, 1182638, 1184277, 1184763, 1185674, 1186139, 1186448, 1186585, 1187433, 1187441, 1189523, 1191909, 1193089, 1193454, 1193838, 1194751, 1194761, 1195285, 1195289, 1195295, 1198191, 1198727, 1200269, 1200424, 1203381, 1210445, 1213429, 1213444, 1215300, 1217623, 1219790, 1221846, 1222890, 1223191, 1223777, 1223780, 1225093, 1225097, 1225100, 1225101, 1225104, 1225106, 1226564, 1228437, 1228615, 1230661, 1232638, 1233368, 1235910, 1236108, 1247756, 1247979, 1247980, 1249976, 1249978, 1250088, 1250344, 1250346, 1250362, 1250473, 1250717, 1251032, 1251063, 1251363, 1251699, 1251732, 1252031, 1252947, 1253039, 1253984, 1254669, 1255159, 1255175, 1255968, 1257486, 1257623, 1257937, 1258465, 1259641, 1259770, 1261108, 1268302, 1281824, 1289403, 1299069, 1301392, 1303096, 1303749, 1322441
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [webvr])

Tracker for perf issues.
Alias: e10s-perf
tracking-e10s: --- → +
Depends on: 1022988
Blocks: 1019560
Keywords: meta
Depends on: 1066342
Depends on: 1065059
Depends on: 1067084
Depends on: 1067523
No longer blocks: 1019560
Depends on: 1019560
Depends on: 1071411
Depends on: 1071868
If someone would fix bug 1008435, that would be a tremendous help towards being able to file better performance bugs for e10s.
Depends on: 1074971
Depends on: 1074992
Depends on: 1076820
Depends on: 1080152
Depends on: 1027967
Depends on: 1080884
Depends on: 1085032
Depends on: 1095020
Duplicate of this bug: 1099401
Depends on: 1099406
A list of Telemetry histograms for Nightly that changed with high likelihood because of e10s: http://alerts.telemetry.mozilla.org/index.html#/detectors/1/alerts/?from=2014-11-07&to=2014-11-11&metrics-filter=
Depends on: 1102926
Depends on: 1108538
Depends on: 1110024
Depends on: 1110503
Depends on: 1107793
Depends on: 1109364
Depends on: 1114355
Depends on: 1113735
Depends on: 1080916
Depends on: 1128137
Depends on: 1128056
Depends on: 1121929
Depends on: 1105891
Depends on: 1126464
Depends on: 1144120
Depends on: 1144345
No longer depends on: 1100252
Depends on: 1145783
Depends on: 1135719
Depends on: 1150036
Depends on: 1150147
Depends on: 1152543
Depends on: 1154197
Depends on: 1152453
Depends on: 1157941
Depends on: 1170609
Depends on: 1162392
Depends on: 1175477
Depends on: 1181074
Depends on: 1182405
Depends on: 1182636
Depends on: 1182637
Depends on: 1182638
Depends on: 1184669
Depends on: 1184763
Depends on: 1189523
Depends on: 1194661
Blocks: e10s-rc
Depends on: 1198727
Depends on: 1198890
Depends on: 1200269
Depends on: e10s-nofxcpows
Depends on: 1209207
Depends on: 1210445
No longer depends on: 1194661
Depends on: 1213444
Depends on: 1213435
Depends on: 1213469
Depends on: 1215300
Depends on: 1219790
Depends on: 1223191
Depends on: 1171653
Depends on: 1178353
No longer depends on: 1144120
No longer depends on: 1210649
No longer depends on: 1213469
No longer depends on: 1124517
Depends on: 1223777
Depends on: 1223780
No longer depends on: 1128137
No longer depends on: 1209207
No longer depends on: 1206914
No longer depends on: 1198890
Depends on: 1198191
No longer depends on: 1213435
No longer depends on: 1185667
No longer depends on: 1184669
No longer depends on: 1183154
Depends on: 1224276
No longer depends on: 1182637
Depends on: 1225093
Depends on: 1225097
Depends on: 1225100
No longer depends on: 1225100
Depends on: 1225101
Depends on: 1225104
Depends on: 1225106
Depends on: 1225476
No longer depends on: 1154197
No longer depends on: 1150147
No longer depends on: 1150036
No longer depends on: 1145783
No longer depends on: 1125175
No longer depends on: 1121929
No longer depends on: 1227275
No longer depends on: 1095781
Depends on: 1228439
Depends on: 1228615
No longer depends on: 1228439
Depends on: 1230661
No longer depends on: 1115683
No longer depends on: 1224276
Depends on: 1182637
Depends on: 1222890
Depends on: 1037179
Depends on: 1247979
Whiteboard: [webvr]
Depends on: 1249978
Depends on: 1250469
Depends on: 1250473
Depends on: 1249665
Depends on: 1250362
Depends on: 1251699
Depends on: 1252031
Depends on: 1252030
Depends on: 1252768
Depends on: 1144120
Depends on: 1251939
Depends on: 1253039
Depends on: 1226564
Depends on: 1253984
No longer depends on: 1249665
Depends on: 1254081
Depends on: 1254087
Depends on: 1254088
This bug is no longer being used to track anything valuable. Documented release criteria are being tracked through https://wiki.mozilla.org/Electrolysis/Release_Criteria

Anything else that should possibly block e10s should be marked tracking-e10s:?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
Depends on: 1251032
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)
> This bug is no longer being used to track anything valuable. Documented
> release criteria are being tracked through
> https://wiki.mozilla.org/Electrolysis/Release_Criteria
> 
> Anything else that should possibly block e10s should be marked
> tracking-e10s:?

The e10s team uses this bug in a major way to track performance related work we're actively working on. I'm fine with closing it out but please do not change any of the bugs attached here.
BTW we have bug list links in the e10s wiki that point to our active performance work if you're looking for a way see that.
Depends on: 1187433
Depends on: 1255159
Depends on: 1254628
Depends on: 1250350
Depends on: 1255175
No longer depends on: 1253386
Depends on: 1255968
Depends on: 1233585
Depends on: 1251063
Depends on: 1257486
Depends on: 1257869
Depends on: 1258609
No longer depends on: 1258609
Depends on: 1261108
Depends on: 666365
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
No longer depends on: 1257869
No longer depends on: 1250469
Depends on: 1268302
Depends on: 1250717
No longer depends on: 1254087
Depends on: 1281824
Depends on: 1289403
Depends on: 1299069
Depends on: 1301392
No longer depends on: 1210842
Depends on: 1322441
Depends on: 1325527
Depends on: 1349840
Depends on: 1354641
Blocks: 1363015
No longer blocks: 1363015
Depends on: 1363015
No longer depends on: 1363015
Depends on: 1363015
No longer depends on: 1363015
Please add a dependency on bug 1318939, slow tab switch time, which seems to be a regression caused by e10s.
You need to log in before you can comment on or make changes to this bug.