Closed Bug 1096933 Opened 5 years ago Closed 5 years ago

Intermittent test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video | AssertionError: time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1) not greater than time.struct_time(tm_year=1900

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure, Whiteboard: xfail)

b2g_macosx64 b2g-inbound opt test gaia-ui-test-functional-3

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=812422&repo=b2g-inbound

02:15:25 ERROR - TEST-UNEXPECTED-FAIL | test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video | AssertionError: time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1) not greater than time.struct_time(tm_year=1900, tm_mon=1, tm_mday=1, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=0, tm_yday=1, tm_isdst=-1)
This appears to be pretty frequent. Can we get a fix, backout, or disabling please? :)
Flags: needinfo?(kgrandon)
I looked, but couldn't immediately find something that would cause this to go intermittent. Florian - any ideas here?
Flags: needinfo?(kgrandon) → needinfo?(florin.strugariu)
I can't reproduce this issue locally  the test is passing without any issue for me.

https://pastebin.mozilla.org/7266682

But I'm on Ubuntu. I can't find any commits that would affect this test. But as this test was passing constantly before this some change have affected us.

Geo I know you are working on a MAC. Can you try to reproduce/investigate this issue?
Flags: needinfo?(florin.strugariu)
Flags: needinfo?(gmealer)
I disabled this test on mac as it's generating a lot of intermittents

Also added the bug to our sprint backlog
QA Whiteboard: [fxosqa-auto-backlog+]
Whiteboard: xfail
Fwiw, I retried this test 30 times on the Mac, but I couldn't reproduce this failure.
test_play_webm_video.py and test_play_ogv_video.py are basically the same kind of tests and they don't seem to fail intermittently on Mac desktop.
(In reply to Martijn Wargers [:mwargers] (QA) from comment #29)
> Fwiw, I retried this test 30 times on the Mac, but I couldn't reproduce this
> failure.

The thing I notice about this test failure is that in the screenshot the screen is very dark.

The video app only does this when the controls are hiding or showing.

I am supposing that the `show_controls` needs a better wait after the tap. The existing wait there may be resolving/returning too quickly.
This reminds me a lot of bug 1047168, where I noticed that there is some awful amount of jank on the video sometimes, which caused the subtest that used video.currentTime to fail.
I suspect something similar might be happening here.
This intermittent failure was MacOS specific. Bug 1139029 disabled Gip on this platform.
Blocks: 1139029
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(gmealer)
You need to log in before you can comment on or make changes to this bug.