Turn off OSX Gip (Gaia UI tests) on all branches

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [capacity])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1139023 +++

Per recent IRC discussion, we're chronically starved for rev5 capacity right now and have very little in the way of short-term prospects for improving things.

When looking at what can be done now to improve things, the question of OSX B2G Desktop tests came up. Right now, we run Gip (Gaia UI tests) on each push. We run these same tests on Linux64 builds on AWS (where we're not nearly as limited by capacity).

Additionally, RelEng is currently in the process of converting the majority of our rev5 test slaves from OSX 10.8 to 10.10. To my knowledge, we don't have any idea what B2G desktop builds will do in this situation, let alone tests on them.

Especially given the long-term plans of moving away from B2G Desktop builds to Mulet, the general consensus seems to be that we're not sacrificing much in the way of test coverage by dropping these tests on OSX for the time-being. OSX test coverage on Mulet can be revisited down the line, hopefully once the longer-term plans for increased slave capacity have also come to fruition.
As long as the Gaia UI Tests for B2G Desktop are kept running on Linux, then I guess it's fine.
(Assignee)

Comment 2

4 years ago
Created attachment 8572088 [details] [diff] [review]
turn off OSX B2G opt tests

This is probably the simplest way to do it if I'm understanding things correctly. Note that I'm explicitly ignoring the multitude of cleanups that could probably be done further down in light of this change. Probably better in the event that this decision gets changed down the line.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8572088 - Flags: review?(coop)
I generally concur with Martijn, but see my related comment at https://bugzilla.mozilla.org/show_bug.cgi?id=1139006#c4
Comment on attachment 8572088 [details] [diff] [review]
turn off OSX B2G opt tests

Review of attachment 8572088 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/build/buildbot-configs/rev/745ac94f8750
Attachment #8572088 - Flags: review?(coop)
Attachment #8572088 - Flags: review+
Attachment #8572088 - Flags: checked-in+

Updated

4 years ago
Duplicate of this bug: 1139006
Depends on: 1095471
Depends on: 1096325
Depends on: 1096933
Depends on: 1099045
Depends on: 1124968
Depends on: 1128843
Depends on: 1131618
Depends on: 1078156
Depends on: 1090930
Depends on: 1092134
Depends on: 1106765
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.