Closed Bug 1097243 Opened 7 years ago Closed 6 years ago

|./mach webapprt-test-chrome| fails on "This copy of Firefox (20141111122617) cannot run Apps, because it is missing the Web Runtime's application.ini file"

Categories

(Firefox Graveyard :: Webapp Runtime, defect, P2)

x86_64
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: myk, Unassigned)

References

Details

After building Firefox from trunk, running ./mach webapprt-test-chrome against the build fails with the exception "This copy of Firefox (20141111122617) cannot run Apps, because it is missing the Web Runtime's application.ini file":

--------------------------------------------------------------------------------
11-11 12:43 > ./mach webapprt-test-chrome
From _tests: Kept 20911 existing; Added/updated 0; Removed 0 files and 0 directories.
SUITE-START | Running 17 tests
Error: Could not find debugger None.
pk12util: PKCS12 IMPORT SUCCESSFUL
MochitestServer : launching [u'/Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/bin/xpcshell', '-g', u'/Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app/Contents/Resources', '-v', '170', '-f', u'/Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmpt12G7t.mozrunner'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '127.0.0.1'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/_tests/testing/mochitest/server.js']
runtests.py | Server pid: 81533
runtests.py | Websocket server pid: 81534
runtests.py | SSL tunnel pid: 81535
runtests.py | Running tests: start.

runtests.py | Application pid: 81536
2014-11-11 12:44:12.950 webapprt-stub[81536:507] MY WEBAPPRT BUILDID: 20141111122617
2014-11-11 12:44:12.952 webapprt-stub[81536:507] found override firefox binary: (null)
2014-11-11 12:44:12.952 webapprt-stub[81536:507] SEARCHING for webapprt, trying: org.mozilla.nightly
2014-11-11 12:44:12.954 webapprt-stub[81536:507] USING FIREFOX : /Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app
2014-11-11 12:44:12.954 webapprt-stub[81536:507] Looking for firefox ini file here: /Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app/Contents/Resources/application.ini
2014-11-11 12:44:12.955 webapprt-stub[81536:507] FIREFOX WEBAPPRT BUILDID: 20141111122617
2014-11-11 12:44:12.955 webapprt-stub[81536:507] This Application has the newest webrt.  Launching!
2014-11-11 12:44:12.956 webapprt-stub[81536:507] Set XUL_APP_FILE to: /Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app/Contents/Resources/Contents/MacOS/webapp.ini
2014-11-11 12:44:12.970 webapprt-stub[81536:507] WebappRT application.ini path: /Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app/Contents/Resources/webapprt/webapprt.ini
2014-11-11 12:44:12.971 webapprt-stub[81536:507] got exception: This copy of Firefox (20141111122617) cannot run Apps, because it is missing the Web Runtime's application.ini file
TEST-INFO | Main app process: exit 0

runtests.py | Application ran for: 0:00:00.068840
zombiecheck | Reading PID log: /var/folders/lp/8t_7y24119720_hjp5wc_4cr0000gn/T/tmpWXSU4wpidlog
Stopping web server
Stopping web socket server
Stopping ssltunnel
WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
runtests.py | Running tests: end.
SUITE-END | took 1s
--------------------------------------------------------------------------------

(I trashed all other copies of Firefox on my system before running tests to ensure the stub didn't try launching the app with a different runtime.)

Of note: console output says the "WebappRT application.ini path" is (/Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/) dist/Nightly.app/Contents/Resources/webapprt/webapprt.ini, but that file doesn't exist.

The parent directory dist/Nightly.app/Contents/Resources/webapprt does exist, except that it isn't a directory, it's a regular file.  Meanwhile, both dist/bin/webapprt/webapprt.ini and webapprt/webapprt.ini do exist, and the former is a symlink to the latter.
(In reply to Myk Melez [:myk] [@mykmelez] from comment #0)
> ...
> 2014-11-11 12:44:12.955 webapprt-stub[81536:507] This Application has the
> newest webrt.  Launching!
> 2014-11-11 12:44:12.956 webapprt-stub[81536:507] Set XUL_APP_FILE to:
> /Users/myk/Projects/gecko-dev/obj-x86_64-apple-darwin13.4.0/dist/Nightly.app/
> Contents/Resources/Contents/MacOS/webapp.ini

This path certainly doesn't look right either...
Priority: -- → P2
Blocks: 1111077
Duplicate of this bug: 1116784
Per bug 1238079, we're going to disable the desktop web runtime and remove it from the codebase, so we won't fix these bugs in it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.