Port MSN application ID changes to allow MSN to connect again

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: clokep, Assigned: clokep)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [1.6-blocking])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is related to bug 964828, but can be done separately (and quickly).

MSN has started dropping connections with the application ID used by libpurple. Updating the application ID allows connections to continue. We need to port https://hg.pidgin.im/pidgin/main/rev/f6a91e6c77a4 and it would help to port https://hg.pidgin.im/pidgin/main/rev/ee51d84aacbf
(Assignee)

Updated

4 years ago
Summary: Port changes to allow MSN to connect again → Port MSN application ID changes to allow MSN to connect again

Comment 1

4 years ago
Hi,

A my friend (blend user), thats using the lastest stable version 1.5, she's says that msn does not work, like is reported in this bug !

Regards

Updated

4 years ago
Whiteboard: [1.6-blocking]

Updated

4 years ago
Depends on: 964828
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1124618
(Assignee)

Comment 3

4 years ago
Created attachment 8555496 [details] [diff] [review]
Port

This ports the two patches, I still get a connection refused error after this though. Maybe something else in our MSN code is too old?
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Attachment #8555496 - Flags: review?(aleth)
(Assignee)

Updated

4 years ago
Attachment #8555496 - Flags: review?(aleth)

Comment 4

4 years ago
Comment on attachment 8555496 [details] [diff] [review]
Port

Review of attachment 8555496 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for looking at this.

So is it worth landing this separately from the libpurple upgrade if it doesn't help?
Attachment #8555496 - Flags: review+

Comment 5

4 years ago
Hi !

I have a good news ;-)
My pidgin 2.10.11 now works well with msn, after serching in the web somme time ;-)

For pidgin users, the solution is there:
https://messengergeek.wordpress.com/2014/11/12/most-third-party-messenger-clients-have-gone-offline-temporarily/comment-page-2/#comment-19396

Another way to solve this bug, but in my case at work with a proxy and firewall this not work, but work at home pc
https://developer.pidgin.im/ticket/16489
http://ismsndeadyet.com/

I tried to modify msn account in instantbird with somme values that in pidgin and isnt workded, fails the connection ! :-(

[01/29/2015 07:07:01 PM] ERROR (@ msn: msn_contact_request_cb http://hg.mozilla.org/comm-central/raw-file/f28ff368b740/purple/libpurple/protocols/msn/contact.c:214)
Operation {} failed. No response received from server.

Regards
(Assignee)

Comment 6

4 years ago
Seems like we need to wait for Pidgin to update before this will work again.
(Assignee)

Comment 7

4 years ago
Per comment 6.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.