SVG onactivate event not working/implemented

RESOLVED DUPLICATE of bug 371728

Status

()

RESOLVED DUPLICATE of bug 371728
4 years ago
4 years ago

People

(Reporter: sava1192, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

1. Create simple svg with onactivate attribute (this event IS in list of svg specs http://www.w3.org/TR/SVG/interact.html#SVGEvents)
<svg height="100" width="100" onactivate="alert('it works')">
  <circle cx="50" cy="50" r="40" stroke="black" stroke-width="3" fill="red" />
</svg> 
(http://jsfiddle.net/p5ycypde/)
2. Click/press enter on SVG


Actual results:

 nothing


Expected results:

activate event fires and create alert with text.

Updated

4 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 371728
You need to log in before you can comment on or make changes to this bug.