Closed Bug 371728 Opened 13 years ago Closed 2 years ago

keyboard navigation: focusin, focusout, onfocusin, onfocusout, onactive events not implemented

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jay, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(3 files)

focusin is one of the events supported by SVG1.1
however the mozilla implementation isn't working.

URL tested on earlier version as animateColor may not be supported currently
onfocusin
onfocusout
onactive

events not implemented at all.
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: animation event handling broken: focusin → onfocusin, onfocusout, onactive events not implemented
#1 Takeshi,
thanks for your input, you may wish to consider opening a separate bug.
this bug refers to declarative animation.

My apologies if this was not clear.

alternatively it may be sensible to widen the scope to include scripting as in onfocusin as well as declarative animation as in focusin.

cheers
Gecko doesn't support the declarative animation at all currently .
see bug 216462.

If you want this bug to refers to declarative animation, "Mark the bug as duplicate of bug #216462"
#3

bug 216462 is a tracking bug.
in fact some aspects were supported see comment#0
original URI 
http://bugs.webkit.org/attachment.cgi?id=13377
tested and working in camino Version 2005042806 (0.8.4Int)

there may also be a regression bug for declarative animation support

please move script bug if you dont believe they are related
I felt that as they both concern keyboard navigation there is some sense in maintaining a tracking bug.
Summary: onfocusin, onfocusout, onactive events not implemented → keyboard navigation: focusin, focusout, onfocusin, onfocusout, onactive events not implemented
#5 attachment was taken from original URI for this bug see #4
(In reply to comment #4)
> there may also be a regression bug for declarative animation support

There is no regression at all. Because the declarative animation has not been implemented.

And Camino 0.8.5 does not support SVG.
You may confuse native support with plug-ins.
#7

thanks for your patience and comments.
you may well be right, unfortunately I cannot tell.
normally asv is indicated when ctrl+clicking in the dropdown menu.
this isn't the case.
How would I check?

this declarative animation code has been around a while.
why was it never implemented?
(In reply to comment #8)
> How would I check?

Type "about:buildconfig" to the location bar. If you find '--enable-svg' in that page, native SVG support is enabled; Otherwise diabled (i.e. plug-ins used).
#8

tried that in Version 2007021902 (1.2+)
--enable-svg isn't present, though SVG is native...
Assignee: general → nobody
QA Contact: ian → general
If the W3C is going to deprecate the DOMFocusIn and other events, then we probably shouldn't fix this. However, we should add support for 'onfocus' and other attributes.

Spec text for onfocusin etc. can be found here FWIW:
http://www.w3.org/TR/SVG11/interact.html#SVGEvents
Blocks: svg11tests
Attached image focusout test
moving to DOM as whilst the effect is SVG the cause is DOM
Component: SVG → DOM: Events
QA Contact: general → events
Depends on: 687787
Attached file testcase
testcase
Attachment #704311 - Attachment mime type: text/plain → text/html
Duplicate of this bug: 1100359
This works these days but you need to give the elements (at least the SVG ones) a tabindex attribute.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
NB you require a testcase, but merely provide an assertion.

typical
You need to log in before you can comment on or make changes to this bug.