"Disconnect" add-on does not work with e10s

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: firefox, Unassigned)

Tracking

({addon-compat})

36 Branch
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
Disconnect 3.14.0 functionality doesn't work with e10s.  The GUI widgets do load, but no content appears to be tracked or blocked.

Opened issue https://github.com/disconnectme/disconnect/issues/340 with upsteam.
William, are you the developer of the "Disconnect" add-on? The add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org or ask Ally on this bug. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
tracking-e10s: --- → +
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066217

Comment 3

3 years ago
I still have this issue with Disconnect but obviously not the one mentioned in bug 1066217.

And as both don't really relate, may we change the status of this one?

Florent
Flags: needinfo?(jorge)
@ Florent: which version of Firefox and Disconnect add-on are you using?

@ Andy: arewee10syet.com's Disconnect entry is green because it points to RESOLVED WONTFIX bug 1066217. We should point Disconnect to this more generic meta bug. Does your new static site use the same Google Spreadsheet the dynamic site did to track add-ons' e10s bugs?
Depends on: 1066217
Flags: needinfo?(amckay)

Comment 5

3 years ago
Nightly 2016-06-12 (50.0a1 ; within the framework the Nightly Reboot project) and Disconnect 3.15.3.1.

Florent
Status: RESOLVED → REOPENED
Flags: needinfo?(jorge)
Resolution: DUPLICATE → ---

Comment 6

2 years ago
cpeterson: arewee10syet updated, its all in github now: https://github.com/andymckay/new-arewee10syet.com/commit/ce3d2ea0d272869cd5709401931461b73a353e8b
Flags: needinfo?(amckay)
(Reporter)

Comment 7

a year ago
This was fixed as Disconnet now shows compatibility with Firefox 57.
Status: REOPENED → RESOLVED
Last Resolved: 4 years agoa year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.