[E10S] Disconnect addon causes Firefox to freeze & hang chrome process during tab operations & a rendering problem

RESOLVED WONTFIX

Status

()

Firefox
Extension Compatibility
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: Roman Stingler, Unassigned)

Tracking

({addon-compat})

35 Branch
x86_64
Linux
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [amo-author-notified], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140911064110

Steps to reproduce:

install disconnect plugin, click left mouse button on D-icon 


Actual results:

the overlay window is stashed


Expected results:

should be displayed as in non-e10s
Blocks: 905436
tracking-e10s: --- → +

Comment 1

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140917030202

I can confirm this bug see the attached screenshot.
It also takes nearly 15 seconds until the overlay opens.
Furthermore when visiting different pages, Firefox locks up and complains about unresponsive script: chrome://disconnect/skin/scripts/vendor/jquery/jquery.js:5
Stopping script, try to continue or debug leads to a complete lockup and the need to kill firefox.

Comment 2

4 years ago
Created attachment 8490798 [details]
screenshot_20140917030202.png

Comment 3

4 years ago
I CCed the only person with a disconnect.me e-mail here to this bug, who happened to be "billy".  I hope that's OK.

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Component: Untriaged → Extension Compatibility
Keywords: addon-compat
Summary: [E10S] rendering problem Disconnect plugin → [E10S] Disconnect plugin causes Firefox to freeze & hang chrome process during tab operations & a rendering problem

Updated

3 years ago
Summary: [E10S] Disconnect plugin causes Firefox to freeze & hang chrome process during tab operations & a rendering problem → [E10S] Disconnect addon causes Firefox to freeze & hang chrome process during tab operations & a rendering problem
The developer has been contacted through AMO.
Duplicate of this bug: 1100400

Updated

3 years ago
Duplicate of this bug: 1176660

Comment 7

3 years ago
This is still not working, but seems much better. Re-notified through AMO.

Updated

3 years ago
Whiteboard: [amo-author-notified]

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Blocks: 1100400
You need to log in before you can comment on or make changes to this bug.