Closed Bug 1100538 Opened 8 years ago Closed 8 years ago

[e10s] rss feeds in bookmarks aren't marked as visited after visiting them

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1101205

People

(Reporter: keeler, Unassigned)

References

(Blocks 1 open bug)

Details

I have a few RSS feeds in my bookmarks toolbar. With non-e10s Firefox, when I visit a link in one of them, the icon changes from orange (unvisited) to grey (visited). With e10s, this doesn't happen.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Hey - looks like bug 988033 is about the functionality of the RSS subscribe button, and this seems more related to what occurs after visiting some or all of a feed we've subscribed to. It wouldn't surprise me if they're both related to the same broken code, but I suspect we might want to test this case separately once bug 988033 is handled. Should we then re-open this bug and block it on bug 988033?
Flags: needinfo?(mrbkap)
indeed I don't think there is a relation, this is due to visits not reaching history for whatever reason (otherwise history would notify livemarks service and they would be marked as visited).

Bug 1098262 is somehow similar, but involves an add-on... so it would be nice to first figure if the bug reproduces with add-ons disabled.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
actually,  this is just a dupe of bug 1101205, if your history doesn't work, your livemarks cannot be marked as visited.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Flags: needinfo?(mrbkap)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.