Closed Bug 1100615 Opened 5 years ago Closed 5 years ago

[Rocketbar] Rocket bar is unresponsive.

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: jthomas, Unassigned)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [2.1-exploratory-3])

Description:

If the user attempts to access the rocketbar from the settings, it is unresponsive.


Repro Steps:
1) Update to Flame Build 20141117040203
2) Open settings App
3) Click the rocketbar at the top of the screen.
4) Observe that rocket bar is not responding. 


Actual:
Rocketbar unresponsive.

Expected:
It is expected that the rocket bar will respond accordingly.

Flame 2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141117040203
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency:100%,
See attached:Logcat & Video
Video: http://youtu.be/ozmRpHwJ6fg
This issue does NOT occur on Flame 2.2 KK (319mb)
Result: Rocketbar unresponsive.

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117000200
Gaia: 086a668942292168f312b3bb53e275fa0886fab1
Gecko: a57b299c5cf2
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Additional note, the rocketbar will respond about 1/8 of the time. This search bar bug is consistent across other apps. However the rocketbar will work accordingly from the Homescreen.
This is broken in the Clock App and FM Radio from what I can see in portrait mode - I cannot get the rocketbar to respond at all when I try to input text.
blocking-b2g: --- → 2.2?
Bug 1099137 may have the offending bug that caused the regression.
Adding smoketest keyword as this is a smoketest blocker: impedes functionality of the status bar in a high-visibility application.
Keywords: smoketest
I am not seeing this on Flame using today's nightly build:

Gaia   4aee256937afe9db2520752650685ba61ce6097d
SourceStamp 7913c9392c5f
BuildID 20141118040205
Version 36.0a1
v188
Confirmed that the issue is no longer occurring on latest central. Rocketbar can now be brought up when in an app and can be utilized normally.

- issue reproduces-
Device: Flame
BuildID: 20141117040025
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

- issue does NOT reproduce-
Device: Flame
BuildID: 20141118082629
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 084441e904d1
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(jmitchell)
Issue no longer repros. Closing as WFM based on comment 6 and comment 7
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Flags: needinfo?(dharris)
Resolution: --- → WORKSFORME
Blocks: 1044736
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.