Closed Bug 1100893 Opened 5 years ago Closed 5 years ago

[Contacts][RTL] Switch for facebook sync is wrong in RTL languages

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P2)

defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: arcturus, Assigned: arcturus)

References

Details

(Whiteboard: [p=1])

Attachments

(5 files)

Attached image 2014-11-18-11-31-42.png
STR:
1. Setup a RTL language
2. Be sure you have connectivity (wifi or 3g)
3. Go to contacts
4. Click on settings

Actual:
- Switch to enable fb sync is on the right overlaping the text.

Expected:
- Switch to enable facebook sync is on the left
Blocks: contacts-rtl
Target Milestone: --- → 2.2 S1 (5dec)
QA Contact: jlorenzo
Assignee: nobody → francisco
Whiteboard: [p=1]
Status: NEW → ASSIGNED
Attached file Pointer to PR 26493
Attachment #8529200 - Flags: review?(sergi.mansilla)
Comment on attachment 8529202 [details]
Fb settings with patch applied v1

Looks good, Only the switch button should be left aligned with the edge of the action button. Thanks!
Attachment #8529202 - Flags: ui-review?(fshih) → ui-review-
Ei Fang,

Actually I made that to not to align with the edge of the action button cause in master is like that.

So I'll change both RTL and LTR cases to be aligned in the same way.
What's with the enlarged FB button? It looks scaled out.
Flags: needinfo?(francisco)
(In reply to Sergi Mansilla [:sergi] (Telenor) from comment #5)
> What's with the enlarged FB button? It looks scaled out.

Hei Sergi, I was following master as base and was that size too. Perhaps we have a bug on that screen in master.
Flags: needinfo?(francisco)
hi,

are you aware of this bug 1076701 ? It should be landing very soon ...
(In reply to Jose Manuel Cantera from comment #7)
> hi,
> 
> are you aware of this bug 1076701 ? It should be landing very soon ...

wrong one this bug 1078174
Depends on: 1078174
(In reply to Jose Manuel Cantera from comment #8)
> (In reply to Jose Manuel Cantera from comment #7)
> > hi,
> > 
> > are you aware of this bug 1076701 ? It should be landing very soon ...
> 
> wrong one this bug 1078174

Better to wait till that bug lands
Attachment #8529200 - Flags: review?(sergi.mansilla)
Francisco, can you/do you need to revisit your patch based on bug #1078174 having landed? 

Fang, since bug #1078174 has landed (and based on Francisco's response to whether or not his patch needs to be revisited), can you revisit the ui-review flag here and see if it makes +? Thanks!
Flags: needinfo?(fshih)
Flags: needinfo?(francisco)
I've checked the latest build. Everything looks fine. The only issue here is the switch button of "Facebook sync friends" is not in RTL position. I've attached the screenshot. Let me know if you need anything. Thanks!
Flags: needinfo?(fshih)
I will wait till bug 1116803 lands, during the review of this one I saw this correctly.
Depends on: 1116803
Flags: needinfo?(francisco)
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Comment on attachment 8529202 [details]
Fb settings with patch applied v1

I've checked in the patch from bug 1116803, the switch button has been solved. Thanks!
Attachment #8529202 - Flags: ui-review- → ui-review+
Comment on attachment 8529200 [details] [review]
Pointer to PR 26493

Hi Sergi, since the adjustments in contacts settings already landed, here is the updated patch.
Attachment #8529200 - Flags: review?(sergi.mansilla)
Comment on attachment 8529200 [details] [review]
Pointer to PR 26493

Changing the review to Jose since Sergi is a bit overloaded
Attachment #8529200 - Flags: review?(sergi.mansilla) → review?(jmcf)
Comment on attachment 8529200 [details] [review]
Pointer to PR 26493

LGTM

thanks
Attachment #8529200 - Flags: review?(jmcf) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/7ea744c4755c8471e8b91a90c93de7672c25e7e4
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8529200 [details] [review]
Pointer to PR 26493

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL bug
[User impact] if declined:
Bad user experience in RTL
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8529200 - Flags: approval-gaia-v2.2?
Attachment #8529200 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been verified successfully on Flame 2.0/3.0.
Reproduce rate:0/5
Attachment:Verify_RTL_Contact.png

Flame 2.2 build:

Build ID               20150204002509
Gaia Revision          a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gaia Date              2015-02-04 00:41:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8669c26fd4a5
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.035932
Firmware Date          Wed Feb  4 03:59:42 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:

Build ID               20150204010225
Gaia Revision          dfebaaa8aab43470f482d09d71137bab840c3ae9
Gaia Date              2015-02-03 18:49:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.043856
Firmware Date          Wed Feb  4 04:39:07 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Attached image Verify_RTL_Contact.png
You need to log in before you can comment on or make changes to this bug.