[FTE] Header does not change to network name on password screen during FTU.

VERIFIED FIXED in 2.1 S9 (21Nov)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ychung, Assigned: mancas)

Tracking

({regression})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(3 attachments)

Reporter

Description

5 years ago
Description:
During FTU, when the user selects a password-protected network, the header of password page does not change to the name of the network. Instead, it displays the header from the previous screen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141118040205
2) Start FTU.
3) On the Wi-Fi network selection screen, select any password-protected network.
4) Observe the header on the password screen.
  
Actual:
The header displays "Select a network" and "Refresh" strings.
  
Expected: 
The header displays the name of the selected network.

Note:
This issue does not occur on the network password screen on Settings app.
  
Environmental Variables:
Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141118040205
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 100%
See attached: screenshot, logcat
Reporter

Comment 1

5 years ago
Posted image WrongHeader.png
This issue does NOT reproduce on Flame 2.1.

Result: The header displays the name of the selected network properly.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141118001204
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ktucker)
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Is this a dupe of bug 1098611? :mancas can you see if your patch also fixes this?
Flags: needinfo?(b.mcb)
Assignee

Comment 3

5 years ago
Hi Sam, my patch does not fix this issue. However, I think both issues are closely related to each other so if you want we can make just one patch that fixes the update UI issue.

What do you think?¿
Flags: needinfo?(b.mcb) → needinfo?(sfoster)
Assignee

Updated

5 years ago
Assignee: nobody → b.mcb
Assignee

Comment 4

5 years ago
Posted file Proposed patch
The issue was caused because we were trying to translate the ssid of the networks which doesn't have any sense.

Besides, I've added unit tests for this part.

Thanks!
Attachment #8525282 - Flags: review?(fernando.campo)
Comment on attachment 8525282 [details] [review]
Proposed patch

Yup, regression from bug 1058985, good catch Manuel.

I left a nit on github. As it's a change not needed to fix the bug, you can add it or not, completely up to you.

Thanks for the tests!
Attachment #8525282 - Flags: review?(fernando.campo) → review+
[Blocking Requested - why for this release]:

This is a regression from 2.1 so nominating 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
> The issue was caused because we were trying to translate the ssid of the
> networks which doesn't have any sense.

Thanks for the patch - yeah if it is a separate bug then we want to land a separate patch for it.
Flags: needinfo?(sfoster)
blocking-b2g: 2.2? → 2.2+
Assignee

Updated

5 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/e28902248db4a8d2582456b0c91561aa5f91c429
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
This is verified fixed on Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)

Result:
The header displays the name of the selected network

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141124100136
Gaia: aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko: be4ba3d5ca9a
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.