[e10s] Possible hang with CPOWs, nested event loop

RESOLVED DUPLICATE of bug 567058

Status

()

Core
DOM: Content Processes
RESOLVED DUPLICATE of bug 567058
4 years ago
3 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10sm5+)

Details

So far this is just a theoretical problem. I'm not sure if it can actually happen.

1. Content process sends an intr message.
2. While waiting for the response, content process dispatches some incoming messages.
3. Parent process sends a CPOW.
4. Content process receives the CPOW and doesn't post the OnMaybeDequeueOne task because AwaitingInterruptReply() is true.
5. Content process, while still dispatching an incoming message, enters a nested event loop (for an alert(), say).

The parent won't do anything at this point because it's waiting for the CPOW reply. The child is also stuck because there's nothing to compel it to dispatch the CPOW.

I've gotten a lot of hangs lately (maybe once every day or two) where the parent is waiting for a CPOW response and the child is in a nested event loop for nsPrompter.js. It seems possible that this could be the cause. Bug 641685 recently added a new source of intr messages in PContent, so the timeline kinda fits.
Assignee: nobody → wmccloskey
tracking-e10s: --- → m5+
Blocks: 1102970
This was fixed by bug 567058.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567058
You need to log in before you can comment on or make changes to this bug.