[evangelism] Ask Bing to serve video loops to firefox

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: rillian, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all][sitewait], URL)

Per comment 27 of bug 944794, today's bing.com is serving an mp4 video loop to Chrome and Safari, but not to Firefox.

Bing has pretty backgrounds on their search page. It's usually a still photo but occasionally they use video loops or scrolling panoramas. They used to be nearly unique in that they offered both Ogg Theora (.ogv) and h.264 (.mp4) versions of their videos to support all major browsers.

Today I'm getting a page with mp4-only in Chrome, and a page with no video at all on Firefox, even though Firefox now supports mp4 playback on Windows and Android and will soon do so on Mac as of the 35 release.
(Reporter)

Updated

4 years ago
Component: Video/Audio → Outreach Request
Product: Core → Developer Engagement
Version: Trunk → unspecified
(Reporter)

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1101824
Moving to Tech Evangelism::Desktop.
Component: Outreach Request → Desktop
Product: Developer Engagement → Tech Evangelism
Blocks: 766964
Whiteboard: [country-all][contactready]

Comment 3

3 years ago
So, has anyone contacted Microsoft about this issue?
(Assignee)

Comment 4

3 years ago
Gary, not yet. The bug is still at [contactready]. When someone takes the time to find a contact, and report the bug, it will be changed to [sitewait].

Anyone is welcome to do that.
(Assignee)

Comment 5

3 years ago
Opera (blink), Firefox (Gecko) do not get the video, just the background.
Safari (webkit), Chrome (blink) get the video.
there is another animated page today.  Still no progress on getting someone to look at this ?
The wait continues.  Another animated page today, but seems that MS is only serving a static image to Firefox.

Can we not find someone to find out why they are not even attempting to serve animated to Firefox ? 

This has been dragging on now almost a year and half now.
(Assignee)

Comment 8

3 years ago
Contacted Microsoft today.
Whiteboard: [country-all][contactready] → [country-all][sitewait]
(Assignee)

Updated

3 years ago
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
(Assignee)

Comment 9

3 years ago
We got an answer from Bing Team

> Videos were purposely disabled in Firefox 
> due to high CPU utilization while the videos 
> were playing. A bug was opened a year ago: 
> Bug 970308
Depends on: 970308

Comment 10

3 years ago
I work on the Bing homepage team. Please feel free to reach out. The above is exactly correct.

Comment 11

3 years ago
Any progress on this?  The videos were turned off quite awhile ago, isn't there a chance that the high CPU utilization no longer exists?

Comment 12

3 years ago
970308 has not been resolved yet.
bug 970308 is resolved. I at least get animation on the halloween bing.com page image, so treating as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.