Closed Bug 1101707 Opened 6 years ago Closed 6 years ago

[FxA] Keyboard disappears immediately when trying to enter email

Categories

(Core :: DOM: Selection, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
blocking-b2g -
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: ychung, Assigned: mtseng, NeedInfo)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [2.1-exploratory-3])

Attachments

(2 files)

Description:
When the user taps the "Enter your email" field, the keyboard pops up and immediately collapses, preventing any user input.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141119040205.
2) Go to Settings > Firefox Accounts.
3) Select "Create Account of Sign In".
4) Tap the "Enter your email" field.
  
Actual:
Keyboard pops up, but disappears immediately.
  
Expected: 
Keyboard stays on the screen properly, and the user can type with the keyboard.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb, KK, Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 100%
See attached: video clip, logcat
http://youtu.be/IjxEXla-h8o
This issue does NOT reproduce on Flame 2.1.

Result: Keyboard stays on the screen properly.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
Build ID: 20141119001205
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression of a core feature which fails smoketests.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
I could not find a Mozilla-Inbound Regression window for this issue because it begins while the gaia bug 1096603 is still active and thus blocks reproduction.  I have included the Mozilla-Central window instead.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141118035525
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141118082629
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 084441e904d1
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 084441e904d1

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7913c9392c5f&tochange=084441e904d1
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
(In reply to Peter Bylenga [:PBylenga] from comment #2)
> [Blocking Requested - why for this release]:
> Functional regression of a core feature which fails smoketests.
> 
> Requesting a window.


Please see comment 3                   :D
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(pbylenga)
QA Contact: jmercado
Looks like a window isn't possible, could be leftover from the fix in bug 1096603?
Flags: needinfo?(pbylenga)
needinfo on Jared for his input, this is a smoketest blocker and a window isn't currently possible.
Flags: needinfo?(6a68)
Bug 1092888 causes this regression. I'll take a look.
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
Component: FxA → Selection
Flags: needinfo?(6a68)
Product: Firefox OS → Core
This bug is causing QA smoketest to fail for 3 straight days in a row now, can we please backout the regressing patch immediately and land the proper fix once we have one ?
Flags: needinfo?(timdream)
Flags: needinfo?(mtseng)
Sure, you can backout bug 1092888.
Flags: needinfo?(timdream)
Flags: needinfo?(mtseng)
I am not sure why I am needinfo'd ... I was simply a bystander with vigilance of looking into smoketest reports :)
This issue because our focus in outer iframe in the beginning, then we click inner iframe's element. So that long tap detector in the SelectionCarets fired incorrectly. I cancel the long tap detector when selection carets are blurred to avoid this issue.
Attachment #8528123 - Flags: feedback?(tlin)
Comment on attachment 8528123 [details] [diff] [review]
Call CancelLongTapDetector when Selection carets are blurred.

Review of attachment 8528123 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #8528123 - Flags: feedback?(tlin) → feedback+
Attachment #8528123 - Flags: review?(roc)
(In reply to Morris Tseng [:mtseng] from comment #9)
> Sure, you can backout bug 1092888.

Given you are the author its cleaner and safer for you to handle the backouts, please backout.
Flags: needinfo?(mtseng)
Comment on attachment 8528123 [details] [diff] [review]
Call CancelLongTapDetector when Selection carets are blurred.

OK, I'll backout bug 1092888.
Flags: needinfo?(mtseng)
Attachment #8528123 - Flags: review?(roc)
Bug 1092888 has been backouted.
Please retest and close if this bug is fixed.
Keywords: qawanted
This issue is no longer occurring on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 (319mb)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(pbylenga)
Closing out then.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(pbylenga)
Keywords: qawanted
Resolution: --- → WORKSFORME
It is back! With build 20141214040212 I don't get keyboard for the Search (on Desktop), search in the Address Book, Email compose box, nowhere.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This bug was specifically about signing up for Firefox Accounts - Matej - can you open a new bug for your issue.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(cepl)
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → -
You need to log in before you can comment on or make changes to this bug.