[Flatfish] [FxA] [FTE] Register/ Log in screen during setup is blank

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: feer56, Assigned: _6a68)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [dependency: marketplace-partners])

Attachments

(4 attachments)

Comment hidden (empty)
Latest 20141111 version from vendor. Upon set up of device, if you choose to register/ sign in for FxA, you are given a blank white screen. There is now way out. You must manually turn the device off and then skip the step in the Setup in order to complete setup.
Component: FxA → Gaia::First Time Experience
Summary: [Flatfish] [FxA → [Flatfish] [FxA] [FTE] Register/ Log in screen during setup is blank
Created attachment 8520211 [details]
2014-11-10-15-13-31.png

Screenshot of the issue.
Duplicate of this bug: 1097182
[Blocking Requested - why for this release]:

This is also happening on Flame v2.2, see bug 1097182 for information.  This fails smoketest and is a functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Component: Gaia::First Time Experience → FxA
Keywords: regression, regressionwindow-wanted, smoketest
Keywords: qaurgent
Please attach a logcat to the bug with Gaia debug traces turned on.
Created attachment 8520880 [details]
logcat_20141111_fxa.txt

Adding logcat (w/ Gaia Debug Traces) of running into the issue.
1) Open 'Settings' app
2) Open 'Developer' tab
3) Enable Gaia Debug Traces, return to 'Settings'
4) Open 'Firefox Accounts' tab
5) Tap 'Create Account or Sign in'
6) Observe broken UI
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: jmercado
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141110015706
Gaia: 59063be9cab6997540c927584c2ff3ceaaeff924
Gecko: 0e01c44e8abd
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141110030358
Gaia: 1ae19a508443600933c3991e5f2ec69766bd01f3
Gecko: 5082fb7509bc
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 59063be9cab6997540c927584c2ff3ceaaeff924
Gecko: 5082fb7509bc

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 1ae19a508443600933c3991e5f2ec69766bd01f3
Gecko: 0e01c44e8abd

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/59063be9cab6997540c927584c2ff3ceaaeff924...1ae19a508443600933c3991e5f2ec69766bd01f3
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
Likely broken by Bug 1095714 - can you take a look Kevin?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
QA Contact: jmercado
I would say that bug 941969 is the much more likely bug to regress in the pushlog, as I believe that may have broken flatfish before?
Flags: needinfo?(kgrandon)
George - any thoughts here?
Flags: needinfo?(gduan)
Created attachment 8521572 [details] [review]
PR to master

Thanks to ni me. 
When I dump the message, I found System is not defined in fxa aggregated js. I believe the error has existed for quite a while.

Perhaps you can help me to do the review? 
Thanks.
Flags: needinfo?(gduan)
Attachment #8521572 - Flags: review?(kgrandon)
Comment on attachment 8521572 [details] [review]
PR to master

I don't have a flatfish to test on right now, but this looks fine to me and makes sense. Thanks!
Attachment #8521572 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/be8b0151d2f9a4c41fc63952128e0b723cd1161d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Verified fixed in 2.2 KK Master Branch on flame devices
Repro Rate: 2/2
Results: FireFox account can be created and viewed in Settings.

Environmental Variables:
----------------------------------------------
Device: Flame 2.2 (Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Gonk: v188 (Shallow Flash)
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
This doesn't seem to be fixed in Flatfish. Bug 1098159 was opened yesterday about the issue first reported here. 

Currently testing with build from vendor: 
20141115
Software: Boot2Gecko 2.2.0.0-prerelease
Firmware Revision: flatfish_20141115-0115
Build #: 20141115
Platform Version: 36.0a1
Build ID: 20141115012414
Update channel: default
Git Commit Info: 2014-1-14 14:56:02 (ccda8433)
(Assignee)

Comment 16

4 years ago
Reopening per comment 15. Can QA take another look at the latest vendor build on flatfish?
Status: VERIFIED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1098159
(In reply to Jared Hirsch [:_6a68] [NEEDINFO pls] from comment #16)
> Reopening per comment 15. Can QA take another look at the latest vendor
> build on flatfish?

Kirkland QA does not have a Flatfish - one of the other labs needs to pick up this request.
Duplicate of this bug: 1098159
(Assignee)

Comment 20

4 years ago
Doh!

I bet this is broken again because bug 1080905 renamed system.js to service.js, but this patch landed with the old name at almost the exact same time.

I'll attach a quick fix.
(Assignee)

Comment 21

4 years ago
Created attachment 8523343 [details] [review]
Github PR 26164

Hey George - Looks like the system.js -> service.js refactor landed with just slightly bad timing for this bug ^_^

kgrandon is out at a conference, do you mind taking a look?

I don't have a flatfish, so I can't confirm this fixes the problem, but it certainly seems like it should.

Thanks,

Jared
Flags: needinfo?(gduan)
Attachment #8523343 - Flags: review?(gduan)
(Assignee)

Updated

4 years ago
Depends on: 1080905
Comment on attachment 8523343 [details] [review]
Github PR 26164

Sorry about the breakage. I feel fine R+ing this since I did the original work to migrate.
Attachment #8523343 - Flags: review?(gduan) → review+
Duplicate of this bug: 1100416
(Assignee)

Comment 24

4 years ago
Thanks, Kevin!

Gip failed to start[1], just retriggered it. I'll merge this fix once it goes green.

[1] https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=c5c56faa7c93
Flags: needinfo?(gduan)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1100022
(Assignee)

Comment 26

4 years ago
Master: https://github.com/mozilla-b2g/gaia/commit/315216dc490bdc56d46ee8f3f514a485b962dde0

Resetting the v2.2 status to 'fixed' so that it can get another round of verification.
Assignee: nobody → 6a68
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-b2g-v2.2: verified → fixed
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1100651
Whiteboard: [dependency: marketplace-partners]
We were seeing this on 2.0.

Comment 29

4 years ago
Verified fixed on Flame 2.2 (319mb/shallow flash) and Flame 2.0 (319mb/shallow flash)

Actual result: 
Login page populates. The user can create and sign in to FxA accounts. 

Device: Flame 2.2 (319mb/shallow flash)
BuildID: 20141118040205
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.0 (319mb/shallow flash)
BuildID: 20141118000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 2bea026d4f86
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.0: --- → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(pbylenga)
(Assignee)

Comment 30

4 years ago
(In reply to Nick Desaulniers [:\n] from comment #28)
> We were seeing this on 2.0.

Hmm. The bug here seems to have been caused by a refactoring that wasn't uplifted to 2.1 or 2.0, so I'm not sure how it could have been fixed.

Nick, I think a separate bug might be warranted. I'll reopen bug 1100651 and we'll have QA try to reproduce there.
Flags: needinfo?(nick)
Removing the flag for 2.0 here then.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: verified → unaffected
Flags: needinfo?(pbylenga)
Flags: needinfo?(nick)
Jared, this is specifically about creating a FxA for the very first time on device.  I'm not sure #1100651 is?
In the latest 2.2 build for Flatfish, this issue no longer occurs.

Environmental Variables:
Flatfish 2.2
BuildID: 20141119014546
Gaia: 0da467aba9ecf354b905f9cc08dfa1a4169659e4
Gecko: 0ce3a6540d11bf82e48dd15c802899a0e93b6486
Version: 36.0a1 (2.2)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(Assignee)

Comment 34

4 years ago
(In reply to Nick Desaulniers [:\n] from comment #32)
> Jared, this is specifically about creating a FxA for the very first time on
> device.  I'm not sure #1100651 is?

Hi Nick,

This particular bug only occurs on 2.2; the patch that caused the regression was never uplifted to 2.0. If you saw this bug on 2.0, as you mentioned in comment 28, then it must have been a different bug with a different root cause. (After looking at bug 1100651 a bit, I actually think it was observed on 2.2, but Harald must have thought he was on 2.0. See my comments there for more details.)

Cheers,

Jared

Updated

4 years ago
Duplicate of this bug: 1100022
Duplicate of this bug: 1100651
Clearing the blocking nom for 2.2? as this is already fixed/verified on that branch per the status flag
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.