"Automatic Zoom" overlaps with arrows in pdf.js.

VERIFIED FIXED in Firefox 35

Status

()

Firefox
PDF Viewer
P2
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: jackwilson128, Assigned: Snuffleupagus)

Tracking

({regression})

35 Branch
Firefox 37
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34 unaffected, firefox35+ verified, firefox36+ verified, firefox37+ verified)

Details

(Whiteboard: [pdfjs-c-ux])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8525793 [details]
Screenshot from 2014-11-19 20:09:52.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141119184317

Steps to reproduce:

In Firefox nightly 36.0a1 (2014-11-19) I opened a PDF.


Actual results:

At the top of the PDF viewer, the "Automatic Zoom" text overlapped the two arrows.


Expected results:

The text should not overlap the arrows. Perhaps the text should be made narrower or the button made wider.

Updated

3 years ago
Component: Untriaged → PDF Viewer
(Assignee)

Comment 1

3 years ago
A work in progress pull request has been submitted at: https://github.com/mozilla/pdf.js/pull/5382.

Comment 2

3 years ago
good=2014-10-02
bad=2014-10-03
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2399d1ae89e9&tochange=b85c260821ab

I'm not sure the bug is in pdf.js, maybe more a layout issue.
Status: UNCONFIRMED → NEW
status-firefox34: --- → unaffected
tracking-firefox35: --- → ?
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
Ever confirmed: true
Keywords: regression
Version: unspecified → 35 Branch

Comment 3

3 years ago
(In reply to Loic from comment #2)
> good=2014-10-02
> bad=2014-10-03
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=2399d1ae89e9&tochange=b85c260821ab
> 
> I'm not sure the bug is in pdf.js, maybe more a layout issue.

You're right, this was caused by a change in layout. However, that change was intentional, see comment #1 and its link.
status-firefox35: --- → affected
status-firefox36: --- → affected
status-firefox37: --- → affected
tracking-firefox35: ? → +
tracking-firefox36: ? → +
tracking-firefox37: ? → +

Updated

3 years ago
Priority: -- → P2
Whiteboard: [pdfjs-c-ux]

Updated

3 years ago
Duplicate of this bug: 1111364
Brendan - any chance there's a low risk uplift coming that can prevent us shipping this regression?  We're going to build our final desktop beta this week but if there was something incredibly low risk we could consider it for RC since this is a user-facing and very visible regression.
Flags: needinfo?(bdahl)
We have a contributor working on patches. They should hopefully be up soon.
Flags: needinfo?(bdahl)
(Assignee)

Comment 7

2 years ago
Created attachment 8544152 [details] [diff] [review]
bug1102063-zoom-arrows.beta.diff
Attachment #8544152 - Flags: review?(ydelendik)
Comment on attachment 8544152 [details] [diff] [review]
bug1102063-zoom-arrows.beta.diff

Approval Request Comment
[Feature/regressing bug #]: Fixes overlap in UI element
[User impact if declined]: UI control/combobox will not look right
[Describe test coverage new/current, TBPL]: manual testing for FF35-37, landed in m-c
[Risks and why]: UI control/combobox will not look right
[String/UUID change made/needed]: n/a
Attachment #8544152 - Flags: review?(ydelendik)
Attachment #8544152 - Flags: review+
Attachment #8544152 - Flags: approval-mozilla-beta?
Attachment #8544152 - Flags: approval-mozilla-aurora?

Updated

2 years ago
Assignee: nobody → jonas.jenwald
Status: NEW → ASSIGNED
Depends on: 1117757
Comment on attachment 8544152 [details] [diff] [review]
bug1102063-zoom-arrows.beta.diff

Let's get this up for our final builds.
Attachment #8544152 - Flags: approval-mozilla-beta?
Attachment #8544152 - Flags: approval-mozilla-beta+
Attachment #8544152 - Flags: approval-mozilla-aurora?
Attachment #8544152 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

2 years ago
Whiteboard: [pdfjs-c-ux] → [pdfjs-c-ux] [checkin-needed-aurora] [checkin-needed-beta]
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/3e875e5a648d
https://hg.mozilla.org/releases/mozilla-beta/rev/fb06fa0600ab

Fixed on trunk by bug 1117757 (which will be merging to m-c within the next few hours).
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox35: affected → fixed
status-firefox36: affected → fixed
status-firefox37: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-ux] [checkin-needed-aurora] [checkin-needed-beta] → [pdfjs-c-ux]
Target Milestone: --- → Firefox 37

Comment 11

2 years ago
Reproduced with Nightly 2014-11-16 on Windows 7 64-bit.
Verified as fixed with 35.0 RC (Build ID: 20150105205925), Aurora 36.0a2 (Build ID: 20150106004007) and Nightly 37.0a1 (Build ID: 20150106030201) with various PDFs (embedded, with annotations and outline view) on Ubuntu 12.03 32-bit, Windows 7 64-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
status-firefox35: fixed → verified
status-firefox36: fixed → verified
status-firefox37: fixed → verified
You need to log in before you can comment on or make changes to this bug.