Closed Bug 1102185 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][STK]There has no terminal response when execute "setup call ->cancel".

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.2 S1 (5dec)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed

People

(Reporter: selee, Assigned: selee)

References

Details

Attachments

(3 files)

The previous bug description is pasted at the bottom.
Here is the summary for the current status:
1. Users go to a option for STK_CMD_SET_UP_CALL.
2. When the call screen is shown, there is a TR 0x10 (STK_RESULT_UICC_SESSION_TERM_BY_USER) sent.
3. The TR(0x10) should not be sent.


We found function stkResTerminate (system/js/icc.js) sends STK_RESULT_UICC_SESSION_TERM_BY_USER when event "visibilitychange" is triggered.
Assignee: nobody → selee
Attached file Pull Request
Hello Fernando, Arthur,

Here is my PR for this bug. Please help to review it. Thank you.

1. Clear the event of onVisibilityChange when any option is clicked.
2. Redirect visibilityChange of Settings to System app. System app handles the event is a better strategy.
3. Add test case to handle on visibility change event from Settings app.
Attachment #8525967 - Flags: review?(frsela)
Attachment #8525967 - Flags: review?(arthur.chen)
Duplicate of this bug: 1093993
Comment on attachment 8525967 [details] [review]
Pull Request

The direction looks good to me. I left some comments in github regarding the naming. Please check, thanks!
Attachment #8525967 - Flags: review?(arthur.chen)
Hi Arthur,
The patch is updated. Please help to see the changes. Thank you.
Flags: needinfo?(arthur.chen)
Comment on attachment 8525967 [details] [review]
Pull Request

LGTM.
Asking Manuel for testing in a real device
Attachment #8525967 - Flags: review?(frsela)
Attachment #8525967 - Flags: review+
Attachment #8525967 - Flags: feedback?(b.mcb)
blocking-b2g: --- → 2.0M+
Comment on attachment 8525967 [details] [review]
Pull Request

Looks good, thanks!
Flags: needinfo?(arthur.chen)
Attachment #8525967 - Flags: review+
Hello Arthur,  Fernando,

Thank you!!


gaia-try PASS: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=4e3698d1d1b2

landed on https://github.com/mozilla-b2g/gaia/commit/80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8525967 [details] [review]
Pull Request

Works fine on device!

Thanks for the patch
Attachment #8525967 - Flags: feedback?(b.mcb) → feedback+
Uplift to 2.0m get conflicts in apps/system/js/icc.js.
Flags: needinfo?(selee)
Attached file Pull Request for v2.0m
Flags: needinfo?(selee)
Blocks: Woodduck_P2
No longer blocks: Woodduck_P2
Blocks: Woodduck_P2
No longer blocks: Woodduck_P2
Duplicate of this bug: 1107797
Comment on attachment 8525967 [details] [review]
Pull Request

This patch can provide better STK user experience in FxOS.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):

[User impact] if declined:
STK feature will be abnormal if the visibility behavior is not fixed.

[Testing completed]:
1. Implement Unit Test and test PASS.
2. Partner tested PASS in their LAB. (see bug 1093993)

[Risk to taking this patch] (and alternatives if risky):

[String changes made]:
Attachment #8525967 - Flags: approval-gaia-v2.1?
Attachment #8525967 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Target Milestone: --- → 2.2 S1 (5dec)
You need to log in before you can comment on or make changes to this bug.