Closed Bug 1102268 Opened 5 years ago Closed 5 years ago

[User story] As a link clicker in a conversation, I want to see content shared with me in real-time.

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla38
Iteration:
38.3 - 23 Feb
Blocking Flags:
backlog Fx38+

People

(Reporter: RT, Unassigned)

References

()

Details

(Whiteboard: [screensharing])

User Story

As a link clicker in a conversation, I want to see content shared with me in real-time.

Acceptance criteria:
* If content is shared already in the conversation as the clicker joins it, he will start seeing the content as he joins the conversation
* If content is shared after the clicker joins the conversation, he will start seeing the content as sharing is initiated
* When content is shared in the room, the clicker view changes as follows:
- The video view gets minimized to leave room for the content
- Content is rendered in the conversation per UX
* When content sharing is stopped by the conversation creator, the conversation view is displayed per the current implementation
No description provided.
Blocks: 1099241
backlog: --- → Fx37?
User Story: (updated)
Summary: [User story] As a link clicker in a room, I want to start seeing the content being shared in real time by the desktop client user as he enables sharing on so that this content can support our discussion. → [User story] As a link clicker in a conversation, I want to see content shared with me in real-time.
Duplicate of this bug: 1102270
Duplicate of this bug: 1102272
Duplicate of this bug: 1102274
backlog: Fx37? → Fx38?
already under prototyping, so work will continue.
backlog: Fx38? → Fx38+
Priority: -- → P1
Whiteboard: [screensharing]
Depends on: 1126289
Depends on: 1126321
Sevaan, looking at the UX again it seems that the rendering of the shared screen is fairly small when compared to the available screen real estate.
Is there a way to allow better use of the screen space?
Flags: needinfo?(sfranks)
(In reply to Romain Testard [:RT] from comment #5)
> Sevaan, looking at the UX again it seems that the rendering of the shared
> screen is fairly small when compared to the available screen real estate.
> Is there a way to allow better use of the screen space?

I'm pretty sure we could remove the max-width which is currently 1000px. This would certainly help on larger screens. Sevaan: if you want to play with this live let me know.
(In reply to Mark Banner (:standard8) from comment #6)
> (In reply to Romain Testard [:RT] from comment #5)
> > Sevaan, looking at the UX again it seems that the rendering of the shared
> > screen is fairly small when compared to the available screen real estate.
> > Is there a way to allow better use of the screen space?
> 
> I'm pretty sure we could remove the max-width which is currently 1000px.
> This would certainly help on larger screens. Sevaan: if you want to play
> with this live let me know.

Actually, we've already removed this limit in the dev version.
Blocks: 1132074
> Actually, we've already removed this limit in the dev version.

Could you post a screenshot of how it looks?
Flags: needinfo?(sfranks)
Blocks: 1132581
No longer blocks: 1132074
All dependent bugs now fixed (or will be once bug 1126321 has been integrated into trunk & dev server), hence marking this as fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Iteration: --- → 38.3 - 23 Feb
You need to log in before you can comment on or make changes to this bug.