Closed Bug 1102300 Opened 6 years ago Closed 6 years ago

[v2.2] SIM settings area missing if user opens "Cellular & Data" too fast

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RobertC, Assigned: arthurcc)

References

Details

(Keywords: regression, Whiteboard: [fromAutomation])

Attachments

(2 files)

Attached image cell_data.png
After opening settings app if the user taps on cellular & data too fast the SIM settings menu will not be displayed.

This issue can be reproduced both manually and with automation:
Repro rate: 5 out of 5

STR:
1. open settings app and tap on "Cellular & Data" without waiting
2. navigate through the settings menus then back to "Cellular & Data"

Expected results:
While in the "Cellular & Data" menu the SIM settings options should be displayed.

Actual result:
SIM settings are missing and do not load even after navigating back and forth (screenshot attached).

The only way to load the SIM settings is to close and re-open the settings app and wait ~5 seconds before tapping on "Cellular & Data".
This was tested on Flame devices, 319MB v188-1 Shallow Flash

Last working b2g-inbound build:
Device firmware (date) 	19 Nov 2014 04:33:25
Device firmware (incremental) 	eng.cltbld.20141119.073312
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	19 Nov 2014 15:43:30
Gaia revision 	8e09627d75ac
Gecko build 	20141119170406
Gecko revision 	65e88009c0b7
Gecko version 	36.0a1

First broken b2g-inbound build:
Device firmware (date) 	06 Nov 2014 03:14:12
Device firmware (incremental) 	eng.cltbld.20141106.061401
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	19 Nov 2014 18:38:04
Gaia revision 	3bc50f192966
Gecko build 	20141119190306
Gecko revision 	9b5ec4beb012
Gecko version 	36.0a1

it looks like this was caused by Bug 1092104
Assignee: nobody → arthur.chen
The root cause is that it accesses to a variable that should refer to moz mobile connections before the variable is initialized. The patch assigned the reference by default and also removed a variable that is no longer used.

EJ, could you help review the patch? Thanks.
Attachment #8526494 - Flags: review?(ejchen)
Thanks, EJ.

master: 1ba138ef243fabbc3714f20a61b6440c172c1a82
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.