Closed Bug 1092104 Opened 5 years ago Closed 5 years ago

[Settings] The first level menu items should never be disabled

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:+)

RESOLVED FIXED
2.2 S1 (5dec)
tracking-b2g +

People

(Reporter: arthurcc, Assigned: arthurcc)

References

Details

(Whiteboard: [p=2])

Attachments

(1 file)

Currently the first level menu items are disabled by default and depending on the hardware states they are enabled a few seconds later. This may cause bad UX because the app feels not "ready" in a reasonable time.

We should always make the first level items enabled and block the menu items in the second level when necessary.
Status: NEW → ASSIGNED
Whiteboard: [p=2]
Target Milestone: --- → 2.2 S1 (5dec)
EJ, could you help review this simple patch? It simply makes all the items enabled as for all related panels we already handle the cases of unavailable sim cards. Thanks.
Attachment #8524398 - Flags: review?(ejchen)
Comment on attachment 8524398 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26225

This looks nice to me. 

Let's make root panel as simple as possible and don't manipulate too much UI on it to make it look more perfect. Note, if there are any problems caused by letting users navigating to sub-panels, we should handle these special cases in sub-panels (like APM) instead of root panel.

r+ & thanks !
Attachment #8524398 - Flags: review?(ejchen) → review+
Thanks, EJ.

master: 3bc50f192966e653cbf99e3ac2e3c799945e996d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocks: 1102300
This patch causes the issue seen in Bug 1102300. Can we get a backout please?
Status: RESOLVED → REOPENED
Flags: needinfo?(cbook)
Resolution: FIXED → ---
Hey Robert,

Per past discussions and agreements with QA, backout requests for regressions
that don't impact our CI infrastructure should go first to the patch author and
then another module peer. This is to minimize risks associated  with other
dependencies that may be currently unknown to people on our team. If a module
peer isn't reachable and this is urgent (i.e. backout and respin nightlies ASAP
because the phone is unusable), please let us know.

i pinged fabrice since i'm about the head out myself if he knows a module peer
Flags: needinfo?(cbook)
redirecting the backout request to arthur
Flags: needinfo?(arthur.chen)
Let's handle the issue in bug 1102300.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.