Resource conflict causes camera ui not to function until camera app is restarted.

VERIFIED FIXED in 2.2 S2 (19dec)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: aosmond)

Tracking

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

1. install torch app from marketplace
2. launch torch
3. launch camera
4. use task manager to close torch app
5. go back to camera
6. try to take a picture

Expected: picture taken
Actual: camera focus circle is seen instead.

Serial: 351dd0f2 (State: device)
Build ID               20141120040205
Gaia Revision          1abe09b4925547699dfdb2d358aed019137c3aa6
Gaia Date              2014-11-20 06:14:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6ce1b906c690
Gecko Version          36.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  39
Firmware Date          Thu Oct 16 18:19:14 CST 2014
Bootloader             L1TC00011880
Also occurs in 2.1:
Build ID               20141120001207
Gaia Revision          f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gaia Date              2014-11-20 01:51:42
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f70a67a7f846
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  39
Firmware Date          Thu Oct 16 18:19:14 CST 2014
Bootloader             L1TC00011880

2.0 has a different bug and is not affected by this bug.
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
blocking-b2g: --- → 2.2?

Comment 2

4 years ago
I am unable to reproduce. 

When I launch torch and launch camera, I see the "Camera is in use by another app" message displayed by Camera App. And when I closed the torch app using task manager and go back to camera, message is no longer displayed and I am able to take a picture. 

Gaia-Rev        1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6ce1b906c690
Build-ID        20141120040205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Hema, here's the repro video.  I can reproduce this bug consistently.
http://www.youtube.com/watch?v=UvMq9T3wDKA

Comment 4

4 years ago
Looks like from the video, torch has captured the camera stream and until it lets go, other apps that need the camera stream cannot use it. 

But there is another issue after the torch app is closed where you are not able to use the camera (its not capturing). Blocking for that reason

Thanks
Hema
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 5

4 years ago
Investigating now that I got the torch app working again (previously broken as noted in bug 1111376).
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
Created attachment 8536795 [details] [review]
Gaia pull request, v1 -- master
Attachment #8536795 - Flags: review?(jdarcangelo)
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.2 S2 (19dec)
Comment on attachment 8536795 [details] [review]
Gaia pull request, v1 -- master

Tested on Flame. LGTM!
Attachment #8536795 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/930bc126d278bf1d3b28e2dbc3f314a288d8e768
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 9

4 years ago
Unable to verify, Torch app is broken on nightly build bug 111137

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141222040204
Gaia: ca6e91e09ef3ab417a0f6b6d6668d43597d85700
Gecko: b915a50bc6be
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
QA Whiteboard: [QAnalyst-Triage?]
Depends on: 111137
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
This issue is verified on Flame 2.2.

Result: The "Camera is in use by another app" message does not appear when Camera is launched while Torch app is running in the background. And the user is able to take a picture after closing the Torch app from Task Manager.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150105010205
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 636498d041b5
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.